PXE network boot/installation of LMDE fails

Archived topics about LMDE 1
Forum rules
c.monty
Level 1
Level 1
Posts: 38
Joined: Tue Apr 26, 2011 4:23 am

PXE network boot/installation of LMDE fails

Postby c.monty » Wed Nov 27, 2013 5:44 am

Hello!
I'm running a NFS, DHCP and TFTP server providing network boot/installation functionality.
The setup should serve as a "Multiboot Server for multiple distros" as described in this tutorial.

The steps to include any distro are basically
    1. Download ISO-file
    2. Mount ISO-file and copy its content to designated directory in NFS server
    3. Adapt the PXE config-files to load kernel (vmlinuz) and initrd accordingly

This approach worked well for Clonezilla, Desinfec't and Debian Wheezy.

Searching the web for a working config to boot/install LMDE I came across with different configs, e.g. this one

Code: Select all

LABEL Linux Mint Debian Edition
KERNEL <path/to/kernel/file>/vmlinuz
APPEND boot=live netboot=nfs nfsroot=<IP NFS Server>:</path/to/extracted/ISO>/lmde initrd=<path/to/initrd/file>/initrd.lz nosplash --


There are different configs using APPEND-parameter boot=casper.
But with this parameter, the boot process stops with a kernel panic.

Using APPEND-parameter boot=live instead, the boot process ends up in the step when files should be loaded from the NFS server.
However this fails with "Network connection error".

My suspicion is, that the interface is not up.
But I don't know how this could be fixed.
There may be an issue with a script called from initrd.lz.

Is there anybody who has a working PXE network boot/install setup for LMDE?

THX

The_Raven
Level 1
Level 1
Posts: 15
Joined: Tue Sep 18, 2012 12:35 pm

Re: PXE network boot/installation of LMDE fails

Postby The_Raven » Sun Feb 23, 2014 9:16 am

Tested today LMDE-UP8 and live-system works (install not tested).
Try with this config:

Code: Select all

KERNEL <path/to/kernel/file>/live/vmlinuz
   APPEND initrd=<path/to/initrd/file>/live/initrd.img vga=791 boot=live config live-media-path=/live netboot=nfs nfsroot=<IP NFS Server>:</path/to/extracted/ISO>/


Edit: DNS is not working! Edit file "/etc/resolv.conf" and put "nameserver 8.8.8.8" in, then it works!


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 5 guests