No grub on install of LMDE on external HD

Archived topics about LMDE 1
Forum rules
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: No grub on install of LMDE on external HD

Postby wayne128 » Mon Aug 04, 2014 4:26 pm

Thank you for providing all the details.
Your motherboard is quite new, however it does not contain the new firmware that I was trying to look for.

All your information are clear now..

Based on your earlier post on the below:
mint@mint ~ $ sudo os-prober
/dev/sde1:LMDE Cinnamon Edition (1):LinuxMint:linux
mint@mint ~ $

Now what I would like you to try is to install LMDE's grub, which should have been already in your /dev/sde1 onto the MBR of the WD external hard disk.

These are the steps :
1. No change on all your setup.
2. Boot computer, F9, select Patriot 32 GB 150 MH to run LM17cinnamon
3. Open a terminal, type this code just to confirm on the location of LMDE

Code: Select all

sudo os-prober

it should give you exactly like before
/dev/sde1:LMDE Cinnamon Edition (1):LinuxMint:linux

4. next code:

Code: Select all

sudo mount /dev/sde1 /mnt

5. next code, remember this, it is /dev/sde at the end of the code , there is no number after the character e

Code: Select all

sudo grub-install --root-directory=/mnt /dev/sde

please capture the terminal results and post here.

if you read something like this
$ sudo grub-install --root-directory=/mnt /dev/sde
Installing for i386-pc platform.
Installation finished. No error reported.

then, you can reboot the computer,
choose the WD 1200BB External
and see what happen.

User avatar
Level 9
Level 9
Posts: 2889
Joined: Mon Mar 11, 2013 11:39 pm

Re: No grub on install of LMDE on external HD

Postby gold_finger » Mon Aug 04, 2014 5:58 pm

I don't want to confuse things here because wayne128 seems to be going in right direction, but just noting a few things.

If you are trying to re-install grub to LMDE, use a live LMDE disk to do it -- not a standard Mint Cinnamon disk.

In your first post, rfharabin, your description of the partitions on that external drive was:
/dev/sdd1 ext4 20GB boot
/dev/sdd2 swap 20GB swap
/dev/sdd3 ext4 60GB home
/dev/sdd4 ntfs 14GB xfer

I put in the " /" and "home" during the install process.

If you meant that the first partition was a boot partition (with a mount point of "/boot") and that the third partition was for both root and home (with mount point of "/"), then you will need to adjust what wayne128 has already posted to fit that scenario. Try the commands he suggested first. If they don't work, then boot again using live LMDE disk and do the following in a terminal:

Code: Select all

sudo mount /dev/sde1 /mnt
cd /mnt

If sde1 really is your root partition, you should see listing similar to this after running the "ls" command:

Code: Select all

bin   cdrom  etc   initrd.img  lib64       media  opt   root  sbin  sys  usr  vmlinuz
boot  dev    home  lib         lost+found  mnt    proc  run   srv   tmp  var

If you don't see something like that, then the sde1 partition is likely just your /boot partition. You will need to mount both the /boot partition and the /root partition; then run the grub install commands. Assuming that is what you need to do, continue on with the following in a terminal:

Code: Select all

cd /
sudo umount /mnt
sudo mount /dev/sde3 /mnt
sudo mount /dev/sde1 /mnt/boot
sudo grub-install --boot-directory=/mnt/boot /dev/sde

(NOTE: if you get a message after trying to mount /dev/sda1 to /mnt/boot that there is no such directory, create the directory by entering sudo mkdir /mnt/boot, then run that mount command again followed by the grub-install command.)

A separate boot partition is not really necessary and does not need to be anywhere close to 20GB in size if you do decide to use one. Swap partition doesn't need to be any bigger than 8-9GB on your system. If you decide to start over at some point in the future, you may want to consider changing the way system is partitioned. For now, once you get booting straightened out, you'll be fine as it is. Just bringing this up for future reference and consideration.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 3 guests