Strange problem with booting?

Archived topics about LMDE 1
Forum rules
1984
Level 2
Level 2
Posts: 66
Joined: Sat Mar 20, 2010 9:27 am

Strange problem with booting?

Postby 1984 » Thu Jan 20, 2011 12:25 am

I currently have mint debian 64 BIT installed on my machine. Most things (except for the usual not auto mounting floppies) seem to be working fine. There is one thing however that is really confusing me.

Sometimes during boot up (at least once or twice a week) while its going over that small white print during boot, I see as its flashing by something about my file systems failed to load. When I log in normally it refuses to take me to my desktop or load anything and instead gives me an "Iceauthority" error. Thing is if I restart the machine about 3 times it goes away and everything works normally. But then in a few days will do the same thing again.

What could be causing this?

User avatar
seeley
Level 7
Level 7
Posts: 1886
Joined: Sun Mar 07, 2010 7:20 am

Re: Strange problem with booting?

Postby seeley » Thu Jan 20, 2011 5:33 am

Hi!
There are several possibilities, one is a wrong UUID;
please compare

Code: Select all

sudo blkid

with

Code: Select all

cat /etc/fstab

and

Code: Select all

cat /etc/mtab

[ E.g., if you have a swap partition.]
seeley
seeley @ Linux multiboot

User avatar
slowcoach
Level 1
Level 1
Posts: 3
Joined: Sun Jan 09, 2011 9:27 am
Location: Oldham, UK.

Re: Strange problem with booting?

Postby slowcoach » Sat Jan 22, 2011 12:41 pm

The problem is that LMDE is using Drive PATHS in etc/fstab while Mint 10 uses UUID's.
Debian RC1 now sets up UUID's so a new LMDE re-spin using the new Debian Installer will solve the problem in the future..........
In the meantime you can edit the etc/fstab file after a successful boot replacing the drive paths with UUID's.

As seeley points out, running “sudo blkid” will give you a list of your drive UUID's.
/dev/sda1: UUID="6e660685-a080-4ee5-a704-95339b2c7497" TYPE="ext4" LABEL="sdb"
/dev/sdb1: LABEL="sdc" UUID="7aee2b49-e9e9-4301-8ff4-88443710d3da" TYPE="ext4"
/dev/sdc1: LABEL="sdd" UUID="3745552f-e117-4782-a205-c9102c0a3982" TYPE="ext4"
/dev/sde1: LABEL="/" UUID="99a02904-a906-40f4-9cad-b8e17e34b3cb" TYPE="ext4"
/dev/sde5: UUID="cfa3f984-cd0e-47d9-8fdf-2e87b9e68584" TYPE="swap"

Edit your etc/fstab file replacing the start of each drive path line with the corresponding drive UUID as listed when you ran sudo blkid example:
The following UUID's are only examples, YOURS WILL BE DIFFERENT....
Replace
/dev/sda1 with
UUID=6e660685-a080-4ee5-a704-95339b2c7497
/dev/sdb1 with
UUID=7aee2b49-e9e9-4301-8ff4-88443710d3da
etc. etc.
KEEP THE SPACING IN THE fstab columns, it is important!.

Comment out any spurious lines in fstab, for instance you may have two proc lines,
you need to end up with fstab looking something like this:

# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=d7537bbc-2605-44a7-a949-0bbb8468af78 / ext4 errors=remount-ro 0 1
# /sdb was on /dev/sdb1 during installation
UUID=c9174c69-3ebd-4a49-9f90-fffa66947a09 /sdb ext4 defaults 0 2
# /sdc was on /dev/sdc1 during installation
UUID=bd75874a-0da4-481e-8327-561a6e3df517 /sdc ext4 defaults 0 2
# /sdd was on /dev/sdd1 during installation
UUID=5f44f905-b29d-4c72-89d5-353e9cdaf89c /sdd ext4 defaults 0 2
# swap was on /dev/sda5 during installation
UUID=78aeab26-ae10-4956-b783-4026388eb6ba none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0

If you have added and formatted a drive AFTER installation making it a STORAGE DRIVE as opposed to a
SYSTEM DRIVE, in fstab you would enter the mount point as /media/sd(x) example: /media/sda and not as shown in blkid


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 9 guests