LMDE installer silently removes Julia's user directories

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 47
Joined: Tue Mar 22, 2011 1:02 pm
Location: Montreal, Quebec, Canada

LMDE installer silently removes Julia's user directories

Postby oysterboy » Mon Jun 13, 2011 9:39 pm

In April, I posted about a possible bug in LMDE's installer :


Just for the record, I reproduced the bug a few days ago, when trying for a second time to install LMDE. My /home partition has different directories, one for each distro (e.g. /home/opensuse, /home/fedora, etc...). My Mint 10 users are in /home/mint/julia/. When I install LMDE, and choose to reuse this /home partition, the LMDE user is created in /home, and /home/mint is removed by the installer :shock: . Other sub-directories of /home are not affected.

User avatar
Level 9
Level 9
Posts: 2721
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: LMDE installer silently removes Julia's user directories

Postby dawgdoc » Fri Jun 17, 2011 5:41 pm

This must be an inconsistent bug. Earlier this month I installed LM9 and LMDE 201101 32 bit on a desktop computer and had no problems.

i first installed LM9 32 bit. I created a /boot partition and / for LM9 as primary partitions, then in an extended partition I created a logical /home to use as a shared partition for both editions. When I installed LMDE I used the manual partition option (I think that was available). LMDE has its own / partition as a logical partition. It shares the /home with LM9, I made sure I did not select the format option for this partition. At install I created a slightly different username than I did for LM9; dr4dpet-lm9 vs dr4pdet-lmd. Also during the install of LMDE I set the bootloader to go in its / partition rather than the MBR. With LM9 I had already set Grub to boot from the MBR and wanted to keep it this way.

I hope some of this sheds light on the issue.

SYSTEM: Compaq Presario CQ62 -- Mint 17 Cinnamon
READING: Little Brother by Cory Doctorow

Return to “Archive”