Fresh Installation Issue [SOLVED]

Archived topics about LMDE 1
Forum rules
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Fresh Installation Issue [SOLVED]

Postby kbkb » Mon Aug 22, 2011 1:43 am


I have been using LMDE from day of of the first release. I have installed it in about 7 computers (mine and friends) during this time.
It is a very good distro but I have had an am having problems with broken packages.

In this particular installation LMDE-64 was added to a windows 7 laptop. The initial installation went fine however as usual, when I tried to update with update manager, I received the usual ...broken packages window - quite annoying. So into terminal I go. I enter

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade

Since I have a slower high speed then most people, I have to wait about 1.5 hours for the updates to come down.

Everything seems to go fine in the terminal until the process comes to an abrupt stop. I see the following in terminal:
ed by signal (Broken pipe)
Selecting previously deselected package libavutil51.
Unpacking libavutil51 (from .../libavutil51_5%3a0.8-0.2_amd64.deb) ...
Preparing to replace libjack0 1:0.118+svn3796-7 (using .../libjack0_1%3a0.121.0+svn4469-2_amd64.deb) ...
Unpacking replacement libjack0 ...
Preparing to replace libattr1 1:2.4.44-2 (using .../libattr1_1%3a2.4.46-3_amd64.deb) ...
Unpacking replacement libattr1 ...
Processing triggers for man-db ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
mysystem@mysystem ~ $ ^C

If someone suggests reinstall it again - well I have already tried 2 other times. I'm sure if I reboot the system I'll see what I saw in earlier attempts of upgrading LMDE. I get a desktop void of Mint - very bland without a menu at all.

I appreciate your help if I can get it.


Last edited by kbkb on Sat Sep 03, 2011 12:46 pm, edited 1 time in total.

User avatar
Level 24
Level 24
Posts: 21374
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Fresh Installation Issue

Postby xenopeek » Mon Aug 22, 2011 2:25 am

I would replace the "sudo apt-get dist-upgrade" with "sudo apt-get upgrade", the first one includes all unsafe updates which the second one avoids (at least on LM11 this is how it works).

You may try:

Code: Select all

sudo apt-get install -f

To fix broken packages issue.

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 7 guests