Screen flashes at boot, grub fails to initialize

Archived topics about LMDE 1
Forum rules
Panruru
Level 1
Level 1
Posts: 6
Joined: Sun Jul 19, 2009 3:09 pm

Screen flashes at boot, grub fails to initialize

Postby Panruru » Tue Apr 17, 2012 5:34 pm

I just installed Mint Debian on a Samsung laptop with an i3 processor. The installation went fine, but when I try to boot it up the screen flashes on and off continuously. When I put in a live cd it starts behaving normally, and I can boot it by selecting "boot from local drive". When I do this, it goes to the grub splash screen and boots as normal. Can anyone shed any light on this problem?

ctigs
Level 1
Level 1
Posts: 4
Joined: Tue Apr 17, 2012 10:47 am

Re: Screen flashes at boot, grub fails to initialize

Postby ctigs » Tue Apr 17, 2012 6:04 pm

Does the system ever make it to the boot menu?

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Screen flashes at boot, grub fails to initialize

Postby zerozero » Tue Apr 17, 2012 6:13 pm

[moved here by moderator]
Image

[ bliss of ignorance ]

Panruru
Level 1
Level 1
Posts: 6
Joined: Sun Jul 19, 2009 3:09 pm

Re: Screen flashes at boot, grub fails to initialize

Postby Panruru » Tue Apr 17, 2012 6:39 pm

ctigs wrote:Does the system ever make it to the boot menu?

No, not unless I use a live CD.

wayne128
Level 10
Level 10
Posts: 3420
Joined: Tue Jul 13, 2010 12:15 am

Re: Screen flashes at boot, grub fails to initialize

Postby wayne128 » Tue Apr 17, 2012 8:09 pm

Try to reinstall grub2 onto MBR of your hard disk.

herostrates
Level 1
Level 1
Posts: 5
Joined: Sat Jan 26, 2013 5:14 am
Location: Poland

Re: Screen flashes at boot, grub fails to initialize

Postby herostrates » Fri Mar 22, 2013 3:23 am

Hi,

I'm facing the same issue with LMDE 2013.03 Cinnamon stable. After successful installation (with Grub in MBR), the computer restarts over and over when it should display the Grub menu. I see only black screen flashing continuously. When I boot from live cd, its Grub shows up and I can boot from local disk using menu and then my own Grub is run and it works fine.

I tried reinstalling Grub and the whole system (with recreating the partition table). Setting Grub timeout to 0 also didn't help. My computer is Samsung NP300E5A laptop.

Thanks in advance for your help.

herostrates
Level 1
Level 1
Posts: 5
Joined: Sat Jan 26, 2013 5:14 am
Location: Poland

Re: Screen flashes at boot, grub fails to initialize

Postby herostrates » Sat Mar 23, 2013 8:49 am

I tried MATE edition and installing Grub on partition instead of MBR. No effect - computer keeps restarting instead of starting Grub.
And for the record - I have disabled EFI boot in BIOS.

Boot repair info:
http://paste.debian.net/243991/

herostrates
Level 1
Level 1
Posts: 5
Joined: Sat Jan 26, 2013 5:14 am
Location: Poland

Re: Screen flashes at boot, grub fails to initialize

Postby herostrates » Sat Mar 23, 2013 2:10 pm

I managed to fix the problem by setting boot flag to sda1 manually.
Why did I have to? Grub is installed in MBR.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 7 guests