cdparanoia disc recognition

Archived topics about LMDE 1
Forum rules
ghicksrn
Level 1
Level 1
Posts: 2
Joined: Mon May 21, 2012 8:17 pm
Location: Tennessee

cdparanoia disc recognition

Postby ghicksrn » Tue Jun 12, 2012 1:08 pm

I have a Dell laptop with LMDE dual-boot with Win 7. In LMDE, my laptop's dvd drive is at /dev/sr0. I have no problems with playing media files or loading data discs. The only problem I have is with cdparanoia and RipperX. When launching either of these programs with an audio disc in my drive, the disc is not recognized. I can easily solve this with the creation of a symbolic link.

Code: Select all

sudo ln -s /dev/sr0 /dev/cdrom

However, when I reboot my computer, the link is gone. Next time I need to rip a disc, I have to create the link again before cdparanoia will recognize the drive. Any ideas on how to make this link persist? I can't find any settings in the configuration of the programs, so I thought the symbolic link was my best bet. I'm open to other solutions as well. I just need the disc recognized, and don't think I should have to recreate the link every time. If there's no other solution, I could change the sudoers file for permission and set the link to be created at startup with a little script. I just think there has to be an easier, and more correct way.

Thanks,
Greg

User avatar
DrHu
Level 17
Level 17
Posts: 7563
Joined: Wed Jun 17, 2009 8:20 pm

Re: cdparanoia disc recognition

Postby DrHu » Tue Jun 12, 2012 2:11 pm

Well, I have to assume, you don't use the /media directory, where a blockID (blkid device, cdrom) would be attached: if you don't then you may also have to alter grub (grub2x) to include device labels instead of only blkid (udev entries..)

Code: Select all

blkid
--gets you the list of hard drive partitions and others, such as CDs..


If you want to show it as your custom location, you do
[code]sudo mkdir /mnt/cdrom
mount /dev/sr0 /mnt/cdrom
--either put those commands in a .sh script when booted for your applications, or fix-up grub2 to use labels and boot will then have them available all the time..

ghicksrn
Level 1
Level 1
Posts: 2
Joined: Mon May 21, 2012 8:17 pm
Location: Tennessee

Re: cdparanoia disc recognition

Postby ghicksrn » Sun Jun 17, 2012 9:22 pm

Been really busy at work and haven't had a chance to get back here. Thanks, DrHu, but I've tried before to do something similar in fstab by adding a line to mount cdrom for all users. It didn't work because this is an audio CD, and therefore, has no file system to mount. I can mount data CDs with no problem automatically on insertion.
RipperX and cdparanoia look for audio CDs at '/dev/cdrom'. Since LMDE did not make '/dev/cdrom', but made '/dev/cdrom1' instead, I am out of luck. The only option I can figure out is to run a shell script at boot to

Code: Select all

sudo ln -s /dev/sr0 /dev/cdrom
I don't understand why I can't make that link and have it persist beyond a reboot.

caramba
Level 1
Level 1
Posts: 20
Joined: Mon Apr 18, 2011 11:26 am

Re: cdparanoia and ripperx disc recognition

Postby caramba » Wed Sep 05, 2012 4:36 pm

I have a similar problem with MINT LMDE AMD64 on an ASUS based desktop, dualboot with other linux. The problem did not occur with DEBIAN 2011.
Hopefully, the solution proposed in this thread also works for me.
One more hint : my CD unit is of IDE type.
I tried to ass an entry into fstab, with no luck. In the basic config, Brasero or VLC seem to detect the audio CD, but ripperx don't. After creating the link
sudo ln -s /dev/sr0 /dev/cdrom
Ripperx is able to open the CD and work, and It is also possible to open it with caja.
Thanks for the tip going around the problem, but a more permanent fix would be nice

caramba
Level 1
Level 1
Posts: 20
Joined: Mon Apr 18, 2011 11:26 am

Re: cdparanoia disc recognition

Postby caramba » Sat Sep 29, 2012 7:32 am

A solution :

viewtopic.php?f=196&t=113567

post : allowing CDrom recognition


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 9 guests