Synaptic can't start after partial UP5

Archived topics about LMDE 1
Forum rules
fuherb
Level 1
Level 1
Posts: 20
Joined: Sun Jan 02, 2011 7:44 am

Synaptic can't start after partial UP5

Postby fuherb » Tue Sep 18, 2012 9:37 pm

Due to the huge number of packages list in UP5, I selected to make small batches of upgrade to avoid a long single process. After some batches however, I cannot restart synaptic. Using terminal to start, I get the following:

fuh@fuh:~$ sudo synaptic
[sudo] password for fuh:

(synaptic:4128): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(synaptic:4128): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(synaptic:4128): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
fuh@fuh:~$ Traceback (most recent call last):
File "/usr/sbin/update-apt-xapian-index", line 97, in <module>
if not indexer.setupIndexing(force=opts.force, system=opts.pkgfile is None):
File "/usr/lib/pymodules/python2.7/axi/indexer.py", line 471, in setupIndexing
self.plugins = Plugins(progress=self.progress, system=system)
File "/usr/lib/pymodules/python2.7/axi/indexer.py", line 94, in __init__
addon = Addon(fullname, **kw)
File "/usr/lib/pymodules/python2.7/axi/indexer.py", line 49, in __init__
self.module = imp.load_source("axi.plugin_" + self.name, fname)
File "/usr/share/apt-xapian-index/plugins/software-center.py", line 13, in <module>
from softwarecenter.db.update import index_name
File "/usr/share/software-center/softwarecenter/db/update.py", line 59, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 27, in <module>
from softwarecenter.backend.channel import is_channel_available
File "/usr/share/software-center/softwarecenter/backend/channel.py", line 25, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 179, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 162, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
fuh@fuh:~$

Any suggestion what is missed?
I can only do software installation now via apt using terminal.

Thanks

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Synaptic can't start after partial UP5

Postby zerozero » Wed Sep 19, 2012 4:53 am

Any suggestion what is missed?

yes, you gave the answer to your question in your post
I selected to make small batches of upgrade to avoid a long single process
After some batches however, I cannot restart synaptic

it won't work and synaptic is not the only app broken probably.
do a

Code: Select all

apt dist-upgrade
and hope for the best
Image

[ bliss of ignorance ]

fuherb
Level 1
Level 1
Posts: 20
Joined: Sun Jan 02, 2011 7:44 am

Re: Synaptic can't start after partial UP5

Postby fuherb » Wed Sep 19, 2012 5:40 am

Thanks,

I did bite the bullet and make all updates already, but problem still exist.

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Synaptic can't start after partial UP5

Postby zerozero » Wed Sep 19, 2012 5:48 am

try to reinstall synaptic

Code: Select all

apt install --reinstall synaptic apt-xapian-index
after that reboot and check again
Last edited by zerozero on Wed Sep 19, 2012 6:13 am, edited 1 time in total.
Reason: corrected a typo
Image

[ bliss of ignorance ]

fuherb
Level 1
Level 1
Posts: 20
Joined: Sun Jan 02, 2011 7:44 am

Re: Synaptic can't start after partial UP5

Postby fuherb » Wed Sep 19, 2012 6:09 am

reinstall synaptic and apt-xapian-index as instructed but no luck, problem still exist.

looking at the terminal output, any more hints?

(synaptic:4120): GLib-GObject-CRITICAL **: g_object_set_data: assertion `G_IS_OBJECT (object)' failed

(synaptic:4120): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(synaptic:4120): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
fuh@fuh:~$ Traceback (most recent call last):
File "/usr/sbin/update-apt-xapian-index", line 97, in <module>
if not indexer.setupIndexing(force=opts.force, system=opts.pkgfile is None):
File "/usr/lib/pymodules/python2.7/axi/indexer.py", line 471, in setupIndexing
self.plugins = Plugins(progress=self.progress, system=system)
File "/usr/lib/pymodules/python2.7/axi/indexer.py", line 94, in __init__
addon = Addon(fullname, **kw)
File "/usr/lib/pymodules/python2.7/axi/indexer.py", line 49, in __init__
self.module = imp.load_source("axi.plugin_" + self.name, fname)
File "/usr/share/apt-xapian-index/plugins/software-center.py", line 13, in <module>
from softwarecenter.db.update import index_name
File "/usr/share/software-center/softwarecenter/db/update.py", line 59, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 27, in <module>
from softwarecenter.backend.channel import is_channel_available
File "/usr/share/software-center/softwarecenter/backend/channel.py", line 25, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 179, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 162, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Synaptic can't start after partial UP5

Postby zerozero » Wed Sep 19, 2012 6:34 am

can you give me the output of

Code: Select all

lsb_release -a
Image

[ bliss of ignorance ]

fuherb
Level 1
Level 1
Posts: 20
Joined: Sun Jan 02, 2011 7:44 am

Re: Synaptic can't start after partial UP5

Postby fuherb » Wed Sep 19, 2012 7:22 am

Here it comes:

fuh@fuh:~$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:core-4.1-ia32:core-4.1-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:cxx-4.1-ia32:cxx-4.1-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:desktop-4.1-ia32:desktop-4.1-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:graphics-4.1-ia32:graphics-4.1-noarch:languages-3.2-ia32:languages-3.2-noarch:languages-4.0-ia32:languages-4.0-noarch:languages-4.1-ia32:languages-4.1-noarch:multimedia-3.2-ia32:multimedia-3.2-noarch:multimedia-4.0-ia32:multimedia-4.0-noarch:multimedia-4.1-ia32:multimedia-4.1-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch:printing-4.1-ia32:printing-4.1-noarch:qt4-3.1-ia32:qt4-3.1-noarch:security-4.0-ia32:security-4.0-noarch:security-4.1-ia32:security-4.1-noarch
Distributor ID: LinuxMint
Description: LMDE Cinnamon Edition
Release: 1
Codename: debian
fuh@fuh:~$

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Synaptic can't start after partial UP5

Postby zerozero » Wed Sep 19, 2012 7:44 am

there's something very wrong in that file, it should show something similar to

Code: Select all

zerozero@deb-kde ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description:    Linux Mint Debian Edition
Release:        1
Codename:       debian


you probably have a /etc/lsb-release.dpkg.old file and that one should be sane;
Image

[ bliss of ignorance ]

fuherb
Level 1
Level 1
Posts: 20
Joined: Sun Jan 02, 2011 7:44 am

Re: Synaptic can't start after partial UP5

Postby fuherb » Wed Sep 19, 2012 8:01 am

I cannot find the file /etc/lsb-release.dpkg.old

I only have a file /etc/lsb-release and it is:

fuh@fuh:~$ cat /etc/lsb-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=1
DISTRIB_CODENAME=debian
DISTRIB_DESCRIPTION="LMDE Cinnamon Edition"
fuh@fuh:~$

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Synaptic can't start after partial UP5

Postby zerozero » Wed Sep 19, 2012 8:26 am

this is surely a long shoot in the dark (but honestly i'm running out of ideas) can you reinstall these packages

Code: Select all

apt install --reinstall mint-meta-debian-cinnamon debian-system-adjustments mintsystem
and give us the output
Image

[ bliss of ignorance ]

fuherb
Level 1
Level 1
Posts: 20
Joined: Sun Jan 02, 2011 7:44 am

Re: Synaptic can't start after partial UP5

Postby fuherb » Wed Sep 19, 2012 8:41 am

Thanks for your input, reinstalled the packages as instructed but still luck is not on our side.

output of lsb_release -a is the same:

fuh@fuh:~$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:core-4.1-ia32:core-4.1-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:cxx-4.1-ia32:cxx-4.1-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:desktop-4.1-ia32:desktop-4.1-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:graphics-4.1-ia32:graphics-4.1-noarch:languages-3.2-ia32:languages-3.2-noarch:languages-4.0-ia32:languages-4.0-noarch:languages-4.1-ia32:languages-4.1-noarch:multimedia-3.2-ia32:multimedia-3.2-noarch:multimedia-4.0-ia32:multimedia-4.0-noarch:multimedia-4.1-ia32:multimedia-4.1-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch:printing-4.1-ia32:printing-4.1-noarch:qt4-3.1-ia32:qt4-3.1-noarch:security-4.0-ia32:security-4.0-noarch:security-4.1-ia32:security-4.1-noarch
Distributor ID: LinuxMint
Description: LMDE Cinnamon Edition
Release: 1
Codename: debian

Synaptic still failed to start. Maybe another note here which might trigger some thoughts? mintupdate also does not work properly, it can start but cannot install packages. mintinstall works without any issue. apt definitely works.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 3 guests