Banshee keeps resetting volume to 100%

Archived topics about LMDE 1
Forum rules
Brian777
Level 1
Level 1
Posts: 2
Joined: Wed Sep 05, 2012 2:52 pm

Banshee keeps resetting volume to 100%

Postby Brian777 » Tue Feb 18, 2014 1:28 am

During the past few days, Banshee has started resetting the volume to 100% whenever I start it up, and sometimes when I just double click on a song in the list. This is extremely annoying, to say the least. Is there any known fix for this other than, say, dumping Banshee and trying Rhythmbox or some other program?

I am using LMDE Cinnamon Edition on a Dell desktop; I forget the model number but it is several years old.

Thanks.

User avatar
hubert.banas
Level 1
Level 1
Posts: 12
Joined: Mon Jan 27, 2014 2:24 pm

Re: Banshee keeps resetting volume to 100%

Postby hubert.banas » Fri Mar 28, 2014 9:41 am

Any updates on this? I'm seeing same behavior.
Thanks

User avatar
killer de bug
Level 12
Level 12
Posts: 4336
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Banshee keeps resetting volume to 100%

Postby killer de bug » Fri Mar 28, 2014 10:35 am

This is related to flat volume.

Solution is explained here: https://wiki.archlinux.org/index.php/PulseAudio
Per-application volumes change when the Master volume is adjusted

This is because PulseAudio uses flat volumes by default, instead of relative volumes, relative to an absolute master volume. If this is found to be inconvenient, asinine, or otherwise undesireable, relative volumes can be enabled by disabling flat volumes in the PulseAudio daemon's configuration file:

Code: Select all

/etc/pulse/daemon.conf

Code: Select all

flat-volumes = no

Code: Select all

$ pulseaudio -k

Code: Select all

$ pulseaudio --start
Image
If it ain't broke, fix it until it is.

User avatar
hubert.banas
Level 1
Level 1
Posts: 12
Joined: Mon Jan 27, 2014 2:24 pm

Re: Banshee keeps resetting volume to 100%

Postby hubert.banas » Fri Mar 28, 2014 5:04 pm

Unfortunately this solution is not working for me. BTW this is only when using Banshee. VLC for example works fine. Any other suggestions?

queson
Level 1
Level 1
Posts: 8
Joined: Mon Jun 13, 2011 5:17 am

Re: Banshee keeps resetting volume to 100%

Postby queson » Fri Mar 28, 2014 5:27 pm

I did as You wrote in your first post- (replaced Banshee with Rythmbox) and it works perfectly

User avatar
hubert.banas
Level 1
Level 1
Posts: 12
Joined: Mon Jan 27, 2014 2:24 pm

Re: Banshee keeps resetting volume to 100%

Postby hubert.banas » Fri Mar 28, 2014 5:33 pm

Yes Rythmbox works for me too but it doesn't integrate as nicely with OS as Banshee does. The current Banshee in LMDE is 2.6.1 and the one in Debian testing is 2.6.2 so maybe trying Banshee 2.6.2 from testing? Any thoughts?

User avatar
hubert.banas
Level 1
Level 1
Posts: 12
Joined: Mon Jan 27, 2014 2:24 pm

Re: Banshee keeps resetting volume to 100%

Postby hubert.banas » Fri Mar 28, 2014 5:46 pm

Another bug in Banshee I noticed when I take master volume down to 0 will bring banshee volume to 0 as well which is expected. But then later I bring master volume up with no problems but banshee still stays at 0.

Zakep
Level 1
Level 1
Posts: 1
Joined: Tue Apr 29, 2014 1:59 pm

Re: Banshee keeps resetting volume to 100%

Postby Zakep » Tue Apr 29, 2014 2:00 pm

Works for me. Post as solved?

Rindo
Level 1
Level 1
Posts: 2
Joined: Sun Jan 11, 2015 5:57 am

Re: Banshee keeps resetting volume to 100%

Postby Rindo » Sun Jan 11, 2015 6:02 am

I have the exact same two problems: the volume is 100% when I play song (which is very annoying with my headphones on) and once I drop the volume to 0%, it stops the sound of the song even when I put the volume back up (the song is playing but with no sound)
I tried the solution above but it's not working.
I'm using lmde also

Rindo
Level 1
Level 1
Posts: 2
Joined: Sun Jan 11, 2015 5:57 am

Re: Banshee keeps resetting volume to 100%

Postby Rindo » Sun Jan 11, 2015 7:12 am

As an alternative, I'm using audacious. It has some plugins that permits it to be closed to tray and have a pretty good integration with cinnamon. just what I needed


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 2 guests