How to install google earth?

Archived topics about LMDE 1
Forum rules
Level 2
Level 2
Posts: 82
Joined: Mon Mar 11, 2013 8:41 am

How to install google earth?

Postby Arp » Mon Jun 09, 2014 11:09 am


I have LMDE 64 bit installed, and I simply cant install google earth. The 64 bit version will not install because ia32-libs is no longer in the repositories, and when I try installing the 32 bit version, it first says that all dependencies are met, but while installing, it failes because of dependency problems ...
If I choose the package from synaptic, it says that the package is broken.

Is there a good and easy way to install it?


Level 4
Level 4
Posts: 317
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: How to install google earth?

Postby py-thon » Mon Jun 09, 2014 12:34 pm

It works in my case with the versions from repo (6.02.2074-r0-1mint2).
But my 64-bit system is an old install, so it still has ia32-libs v.1:0.5 as a dependency.
What I had to do on both systems 64-bit and 32-bit was to change the name of /opt/google/free/ (to anything you like) to make Google Earth work.

v7 from did install (when I tried on my 64-bit-system in March), but after install only works on the first start and then never again.

Have you tried with ia32-libs from Wheezy-repos? It is v.1:0.4 so it might work.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: Sparky 32 bit Mate+mintmenu

Level 9
Level 9
Posts: 2987
Joined: Fri Aug 19, 2011 3:46 am

Re: How to install google earth?

Postby Monsta » Tue Jun 10, 2014 3:16 am

Level 1
Level 1
Posts: 7
Joined: Sun Apr 06, 2014 12:04 pm

Re: How to install google earth? SOLVED

Postby newtusmaximus » Mon Jun 16, 2014 9:05 am

Re removing file. on Google Earth (beta) 32 bit. Mint Maya. Purpose to remove the HTTP Error when searching.
Have tried deleteing Libcurl as suggested. However unable to rename or delete as I don't have "permission." Not owner.
Please how do I resovle the problem. Thank you

SOLVED - Had to go into terminal NOT GUI

su and password to get into root
rm /opt/google/earth/free/ = To remove file
Then close terminal and reboot Google Earth. Search now works .

Hope this helps someone - Probably elsewhere in "Mint History"

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests