Firefox 30 breaks Citrix [SOLVED]

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 9
Joined: Sun Mar 30, 2014 8:47 pm

Firefox 30 breaks Citrix [SOLVED]

Postby dct1970 » Wed Jun 18, 2014 2:09 pm

Hopefully this will be helpful to someone out there.

Recently my Citrix ICA Client [Receiver] no longer launched the remote desktop in Mint 13. After determining that the remote side did not have a problem [due to recent upgrades], I gave up on Mint 13 and tried my brand new LMDE 201403 install on another machine. Citrix successfully launched the remote desktop...until the next round of updates were applied to LMDE.

After looking at what had updated in both, I suspected Firefox 30 [FF30] to be the problem. So I completely reinstalled LMDE and applied changes one at a time with successful Citrix sessions between each update. The last updated was FF30 and then Citrix wold not launch the desktop. So FF30 was the problem.

I read the release notes for FF30 and saw that plugins were all defaulted to "ask to activate". I changed the Citrix plugin to "always active" and that solved the problem.

Don't know if future FF upgrades will default all plugins back to "ask to activate" but that will be a pain if it does. Easy fix but still a pain.

There is another post in Mint Forums in Spanish [I think] that appears to be dealing with this issue but I wasn't for sure so I decided to post here for other monolinguists like myself. :D

Level 1
Level 1
Posts: 7
Joined: Sat Aug 21, 2010 4:52 am

Re: Firefox 30 breaks Citrix [SOLVED]

Postby ugobob99 » Mon Jul 28, 2014 4:26 am

Thank you so much!!!
So simple solution yet so elusive...
I was about to install an older version of Mint on a virtual machine to get Citrix working again... your post saved me a lot of work.

Return to “Archive”