LMDE DVD "Copy To..." gone from Nautilus after updates

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 2
Joined: Sun Jan 02, 2011 11:34 pm

LMDE DVD "Copy To..." gone from Nautilus after updates

Postby codepone » Tue Jan 18, 2011 6:46 pm

After some recent updates (mid-January 2011) the "Copy To..." command that normally appears above the "Check Disk..." command when right clicking on a DVD icon has disappeared. The icons I'm referring to are those that appear on the GNOME desktop when a DVD is inserted or the one listed with other available storage in the "Computer" window. I believe this code is part of Nautilus from my investigations on Ubuntu in the past.

The "Copy To..." command can be used to make a physical copy of a DVD or to rip the DVD to an ISO file. I've used it dozens of times in Ubuntu to rip ISO files of DVDs and it has worked very reliably.

I haven't seen other reports on the forums yet of others experiencing these problems.

Several days ago my friend reported this problem to me on her LMDE system. She has an LMDE 201009 32-bit system that has received the automatic updates that I understand to have updated her system to be equivalent to the 201012 release. I have a recent clean install of LMDE 201012 amd64. At the time she reported the missing "Copy To..." command, mine was still available. After a bunch of updates yesterday, my "Copy To..." is gone too! I hadn't updated for a little over a week. Nautilus didn't seem to be changed though. We are both running somewhat different hardware (desktop vs laptop, different manufacturers, etc).

My "Copy To..." is still gone after multiple reboots and a new set of updates today.

Here is a list of the upgraded packages likely to contain the source of the problem:
[extracted from /var/log/dpkg.log by searching for the "upgrade" lines and stripping out the timestamp and "upgrade" literal]

console-setup 1.67 1.68
firmware-atheros 0.27 0.28
firmware-bnx2 0.27 0.28
firmware-bnx2x 0.27 0.28
firmware-intelwimax 0.27 0.28
firmware-ipw2x00 0.27 0.28
firmware-ivtv 0.27 0.28
firmware-iwlwifi 0.27 0.28
firmware-linux 0.27 0.28
firmware-linux-nonfree 0.27 0.28
firmware-qlogic 0.27 0.28
firmware-ralink 0.27 0.28
firmware-realtek 0.27 0.28
gnome-keyring 2.30.3-4 2.30.3-5
grub-common 1.98+20100804-11 1.98+20100804-13
grub-pc 1.98+20100804-11 1.98+20100804-13
initscripts 2.88dsf-13 2.88dsf-13.1
installation-report 2.43 2.44
keyboard-configuration 1.67 1.68
libgcr0 2.30.3-4 2.30.3-5
libgp11-0 2.30.3-4 2.30.3-5
libncurses5 5.7+20100313-4 5.7+20100313-5
libncursesw5 5.7+20100313-4 5.7+20100313-5
libpam-gnome-keyring 2.30.3-4 2.30.3-5
libperl5.10 5.10.1-16 5.10.1-17
lsb-base 3.2-23.1 3.2-23.2squeeze1
lsb-release 3.2-23.1 3.2-23.2squeeze1
man-db 2.5.7-7 2.5.7-8
ncurses-base 5.7+20100313-4 5.7+20100313-5
ncurses-bin 5.7+20100313-4 5.7+20100313-5
perl 5.10.1-16 5.10.1-17
perl-base 5.10.1-16 5.10.1-17
perl-modules 5.10.1-16 5.10.1-17
python 2.6.6-3+squeeze4 2.6.6-3+squeeze5
python-django 1.2.3-2 1.2.3-3
python-minimal 2.6.6-3+squeeze4 2.6.6-3+squeeze5
schroot 1.4.16-1 1.4.19-1
schroot-common 1.4.16-1 1.4.19-1
sysv-rc 2.88dsf-13 2.88dsf-13.1
sysvinit 2.88dsf-13 2.88dsf-13.1
sysvinit-utils 2.88dsf-13 2.88dsf-13.1

Anyone else having this problem?

You can test it by putting a DVD in your system and looking for the "Copy To..." command on the context menu for the DVD icon.

User avatar
Level 5
Level 5
Posts: 818
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: LMDE DVD "Copy To..." gone from Nautilus after updates

Postby tenfoot » Wed Jan 19, 2011 4:10 pm

The same result here. However, I've never noticed it before you mentioned it. Is it a problem, though? Clicking on "Computer" and then right clicking on the DVD icon results in the "Copy" option being available for me.

Would be very interested to know whether the action you expect has been available in the past. My memory is not the best :oops:

Level 1
Level 1
Posts: 2
Joined: Sun Jan 02, 2011 11:34 pm

Re: LMDE DVD "Copy To..." gone from Nautilus after updates

Postby codepone » Wed Jan 19, 2011 10:58 pm

Thanks for your help.

In my case the "Copy To..." command is gone from Computer as well as the GNOME Desktop. As previously mentioned this missing command can be used to duplicate a DVD to new DVD disk or to create an ISO file.

When I right click the DVD icon under Computer, the menu doesn't contain "Copy To..." but it does contain a command called "Copy to" with an arrow to a submenu that contains "Other pane", "Home Folder" and "Desktop". I'll refer to this "Copy to" with the arrow as "Copy to ->" to clearly distinguish it from "Copy To...". The arrow is actually a black triangle at the very right of the menu item.

"Copy to ->" is in a section of the context menu with commands like "Make Link", "Rename..." and "Move to" while "Copy To..." was grouped with "Check Disk...", "Open in Terminal", etc. I believe this is a distinct command from the "Copy To..." that rips DVDs. When I run this "Copy to ->" on the DVD and choose a destination like "Desktop", an error occurs (title: "Error while Copying CD/DVD Drive: DEFAULTNTSC_SCN", details: "Can't open mountable file").

So "Copy to ->" doesn't bring up the normal DVD Copying dialog box where you can create an ISO file. It seems like a distinct Nautilus command to copy directories and files to one of the specified destinations. I tested it by copying both a file and a directory on the DVD to the Desktop and each copied successfully.

Are you (or anyone else) with an up-to-date LMDE able to bring up the dialog box to create an ISO file from your Computer DVD icon?

Is anyone aware of a workaround?

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 5 guests