When will a Firefox 4 package be available for LMDE users?

Archived topics about LMDE 1
Forum rules
natex
Level 1
Level 1
Posts: 6
Joined: Sun Nov 22, 2009 6:25 pm

When will a Firefox 4 package be available for LMDE users?

Postby natex » Tue Mar 29, 2011 9:21 am

Firefox 4 is now considered stable and has been officially released for about a week now. Is there some place where I can download an official Firefox 4 package for LMDE?

natex

User avatar
MALsPa
Level 8
Level 8
Posts: 2053
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: When will a Firefox 4 package be available for LMDE user

Postby MALsPa » Tue Mar 29, 2011 10:04 am

I'd download it directly from Mozilla.

natex
Level 1
Level 1
Posts: 6
Joined: Sun Nov 22, 2009 6:25 pm

Re: When will a Firefox 4 package be available for LMDE user

Postby natex » Tue Mar 29, 2011 5:58 pm

I'll take that as a "no".

nykur
Level 1
Level 1
Posts: 13
Joined: Wed Mar 30, 2011 11:15 pm

Re: When will a Firefox 4 package be available for LMDE user

Postby nykur » Wed Mar 30, 2011 11:19 pm

I second this query. I'd much rather wait for the official LMDE repo's but when should it land there? Surely any day now? :-)

User avatar
MALsPa
Level 8
Level 8
Posts: 2053
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: When will a Firefox 4 package be available for LMDE user

Postby MALsPa » Wed Mar 30, 2011 11:47 pm

OK, hopefully for LMDE users who want it, FF4 will be available soon. I didn't mean to be flip with my reply -- in Debian, I've gotten used to installing Firefox directly from the Mozilla site, obviously because the Debian repos have Iceweasel but not Firefox.

It's really no big deal, from what I've seen. Most of the distros I use are kinda behind on Firefox (PCLOS is a notable exception to that), so I prefer to install the one from Mozilla -- I did the same thing even in Mint 9 (although I haven't tried FF4 in Mint 9 yet).

Anyway, it's a an option for those who don't want to wait, but maybe you won't have to wait long, I don't know.

User avatar
vrkalak
Level 12
Level 12
Posts: 4393
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: When will a Firefox 4 package be available for LMDE user

Postby vrkalak » Wed Mar 30, 2011 11:57 pm

As a rule, in the past, Firefox has not found support from Debian. They had issues.

Debian uses the Iceweasel browser (basically an unbranded Firefox) ... but, the version in the Debian testing repros is a few versions behind Firefox.
I think, they are still with Iceweasel-3.6.15 . . . I use Iceweasel-4.0 with all my Debian-based OS'

I did download Iceweasel-4.0 as a .deb package but, I had to manually install all the related xul-runner dependencies.

They say that Debian and Mozilla have worked out their differences, and you can now get the original Firefox in the unstable repros. But, I haven't seen it.
Image
:: Debian-Sid (Xfce/Fluxbox) :: LinuxMint-18 (LTS) LXDE w/Openbox ::
Registered Linux User: #497031 :: My DeviantART Page

User avatar
MALsPa
Level 8
Level 8
Posts: 2053
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: When will a Firefox 4 package be available for LMDE user

Postby MALsPa » Thu Mar 31, 2011 12:45 am

Some comments about Iceweasel 4 (and Firefox 4) in Debian:

http://forums.debian.net/viewtopic.php?f=10&t=62057

wayne128
Level 10
Level 10
Posts: 3425
Joined: Tue Jul 13, 2010 12:15 am

Re: When will a Firefox 4 package be available for LMDE user

Postby wayne128 » Thu Mar 31, 2011 12:50 am

MALsPa wrote:Some comments about Iceweasel 4 (and Firefox 4) in Debian:

http://forums.debian.net/viewtopic.php?f=10&t=62057


I follow some procedure in that thread:
here is the link to some detail on this forum
viewtopic.php?f=141&t=69420

mozilla.debian gave me iceweasel 4.0-1

experimental gave me iceweasel 4.0-3. I am using it and it loaded very fast compared with 3.5.17/18

devnet
Level 1
Level 1
Posts: 11
Joined: Tue Apr 21, 2009 10:25 am

Re: When will a Firefox 4 package be available for LMDE user

Postby devnet » Thu Mar 31, 2011 12:15 pm

Honestly, something needs to give here...

It seems it would be easier for LMDE to just switch to iceweasel...and that would seem to be just fine for most users. Installing manually is NOT a good way to do things unless you are an advanced user...because most people will forget to update it after they install it manually and won't be notified when a new version is available...afterall, that's what repositories are all about...providing secured and signed installation packages for a distribution of Linux.

So...if it were me, I'd stop reinventing the wheel and just use iceweasel. Of course, I don't make decisions like this for LMDE...I can only point out when I see inefficiency.

rdonnelly
Level 4
Level 4
Posts: 440
Joined: Thu Nov 27, 2008 9:38 pm

Re: When will a Firefox 4 package be available for LMDE user

Postby rdonnelly » Thu Mar 31, 2011 1:47 pm

I am still using FF 3.6.13. I had already forgotten that I did not get ver 4 yet. Did you have to remind I am not cool :mrgreen:
The OS: Linux Mint 17.3 KDE
The Hardware: Dell 17R Special Edition, Intel Quad Core, i7 - 3.40 GHz, 8 GB Ram, HD 1TB
Video NVIDIA GeForce GT 650M 2GB
The Name: Bob

dfx
Level 1
Level 1
Posts: 34
Joined: Sun Nov 14, 2010 12:35 pm

Re: When will a Firefox 4 package be available for LMDE user

Postby dfx » Thu Mar 31, 2011 2:12 pm

The most important fact for me in installing Iceweasel was, that Debian patches vulnerabilities and Mint does not. Versions are not that important for me. Iceweasel seems to run a bit quicker and smoother than Firefox does

devnet
Level 1
Level 1
Posts: 11
Joined: Tue Apr 21, 2009 10:25 am

Re: When will a Firefox 4 package be available for LMDE user

Postby devnet » Thu Mar 31, 2011 2:12 pm

Oh it's not the cool factor...it's the speed.

It's MIND NUMBINGLY fast now. Seriously....it's leaps and bounds better. That's all I'm after.

natex
Level 1
Level 1
Posts: 6
Joined: Sun Nov 22, 2009 6:25 pm

Re: When will a Firefox 4 package be available for LMDE user

Postby natex » Fri Apr 01, 2011 12:08 am

It has nothing to do with the "cool factor". Sync bookmarks to multiple machines is much easier, It's very fast, and looks so much better. And the Awesome Bar! I don't know what it takes to keep LMDE (tip of the hat to the maintainers' hard work), but if it was me, I would have had FF4 packaged up and ready to go for the masses. Even Slackware has had FF4 packages available since the betas.

Firefox 3 did come with the initial LMDE install so I just expected it to be updated when a major release came out. It's THE killer app on every major PC platform. 50 million downloads and growing. http://glow.mozilla.org/ Keep in mind I'm also just hoping LMDE stays successful.

devnet
Level 1
Level 1
Posts: 11
Joined: Tue Apr 21, 2009 10:25 am

Re: When will a Firefox 4 package be available for LMDE user

Postby devnet » Fri Apr 01, 2011 11:50 am

For those of us that can't wait....I've posted a small 'how-to' on my blog:

http://linux-blog.org/install-firefox-4 ... tion-lmde/

Hopefully this will help a few to experience the Firefox 4 goodness immediately instead of waiting.

User avatar
MALsPa
Level 8
Level 8
Posts: 2053
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: When will a Firefox 4 package be available for LMDE user

Postby MALsPa » Fri Apr 01, 2011 1:03 pm

Another approach:

Well, I haven't tried this in LMDE, but I used this approach in Debian Squeeze and also in Mepis, and haven't run into any problems because of it. Single-user system, though.

Check out the instructions for "Installing outside of a package manager," here: http://support.mozilla.com/en-US/kb/Ins ... on%20Linux

It's basically doing the same thing as devnet's instructions except Firefox will be installed in the home directory and the old Firefox is still present. You'll still have to create a new launcher and/or menu entry for the new Firefox (unless you only want to start it from the terminal using ~/firefox/firefox).

natex
Level 1
Level 1
Posts: 6
Joined: Sun Nov 22, 2009 6:25 pm

Re: When will a Firefox 4 package be available for LMDE user

Postby natex » Fri Apr 01, 2011 2:45 pm

@malspa and devnet,

Thanks for providing alternatives while we wait.

natex

nykur
Level 1
Level 1
Posts: 13
Joined: Wed Mar 30, 2011 11:15 pm

Re: When will a Firefox 4 package be available for LMDE user

Postby nykur » Mon Apr 18, 2011 6:16 am

So... any news yet? What's the situation with the FF package anyway? Obviousley it's not from Debian repos and if it came from Romeo it would surely have been updated by now. If it's been included as a "stand alone" package set to be updated from the Mozilla site I'd really appreciate some guidance, as I just can't find the "update" field, even running as root.

I really hope one of the devs reads this and can provide me with an answer, as I really haven't found it on the forums yet (I'm sorry if I've overlooked something). I know the package is out there and can be installed easily enough, but I'd really like to keep my nicely configured stock FF while benefitting from FF4 niceness. So the ideal situation would be upgrading "normally" from repos:-)

User avatar
kmb42vt
Level 5
Level 5
Posts: 949
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: When will a Firefox 4 package be available for LMDE user

Postby kmb42vt » Mon Apr 18, 2011 11:44 am

What people need to understand about LMDE is that Firefox and Thunderbird for Debian and thus LMDE are now packaged and updated by Clem and Co and have been for awhile now (. Why this hasn't been done for Firefox 4.0 and the latest Thunderbird lately I haven't a clue but I would surmise it may be be due to the work that needs to be put into LM 11 (main edition) which has taken a significant turn away from the stock Ubuntu base (Using Gnome 3 without gnome-shell instead of Gnome 2.32 with Unity). That plus "ikey" having to leave Mint due to personal reasons has probably slowed development right down.

I'd go find the reference to Firefox and Thunderbird for Debian and thus LMDE being packaged now by Mint but it seems that everything but the Mint forums are down for the count including the repos. So here's an early reference from the Crunchbang Staler forums:

http://crunchbanglinux.org/forums/topic ... n-statler/

Until things get straightened out I suggest using the Foxtester add-on for Firefox that allows you to install and run as many versions of Firefox side by side as you wish. It also allows you to set one of them as the system default. It's made for Ubuntu users but works fine on LMDE although you may have to change the menu path entries Firefox manually after you set a newer version as default. Works a treat for me.

Foxtester (latest): http://www.webgapps.org/addons/foxtester

Just make sure you follow the instructions. It's fairly easy though.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests