Difficulties Authenticating With Twitter in Clients

Archived topics about LMDE 1
Forum rules
malpha
Level 1
Level 1
Posts: 15
Joined: Tue Mar 29, 2011 12:58 pm

Difficulties Authenticating With Twitter in Clients

Postby malpha » Mon Apr 04, 2011 4:38 pm

Hi all,

I've been trying to use a few different Twitter clients (Echofon in Firefox, Gwibber, and Hotot), but I'm having problems signing into them. The only one I can sign into is ChromedBird, but I'm moving back to Firefox 4. Here's the errors I'm getting:

Echofon:
Authentication failed with user "screwdestiny" (Failed to validate oauth signature and token. Check your computer's clock. OAuth requires correct timestamp.)

[My clock is correct, btw]

Gwibber:

Code: Select all

Traceback (most recent call last):
  File "/usr/share/gwibber/plugins/twitter/gtk/twitter/__init__.py", line 71, in on_twitter_auth_clicked
    tokendata = urllib2.urlopen(request.http_url, request.to_postdata()).read()
  File "/usr/lib/python2.6/urllib2.py", line 126, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.6/urllib2.py", line 397, in open
    response = meth(req, response)
  File "/usr/lib/python2.6/urllib2.py", line 510, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python2.6/urllib2.py", line 435, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.6/urllib2.py", line 369, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.6/urllib2.py", line 518, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 401: Unauthorized

[This is what happens when I click the Authorize button]

Hotot:

Code: Select all

{"type":"GET","url":"https://api.twitter.com/oauth/request_token?oauth_consumer_key=SCEdx4ZEOO68QDCTC7FFUQ&oauth_nonce=2813318306580186&oauth_signature=bhO0CVpIBp60xVrcnnw%2Fa%2BRnACI%3D&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1301935005&oauth_version=1.0","data":{}}

[This is what happens when I click the button to allow Hotot to gain access]

I guess there's something wrong for me witih OAuth? I pressed the Facebook button in Gwibber and that loaded up the Facebook page, but neither Twitter or identi.ca would load up the authorize page.

User avatar
ThistleWeb
Level 5
Level 5
Posts: 898
Joined: Fri Mar 25, 2011 9:59 am
Location: Scotland
Contact:

Re: Difficulties Authenticating With Twitter in Clients

Postby ThistleWeb » Mon Apr 04, 2011 6:05 pm

Twitter changed their API to require clients to change their code, by now most clients have changed their code to it works again, but the Debian repos may still have older versions of these applications which are not updated yet.
Crivens!

malpha
Level 1
Level 1
Posts: 15
Joined: Tue Mar 29, 2011 12:58 pm

Re: Difficulties Authenticating With Twitter in Clients

Postby malpha » Mon Apr 04, 2011 8:42 pm

ThistleWeb wrote:Twitter changed their API to require clients to change their code, by now most clients have changed their code to it works again, but the Debian repos may still have older versions of these applications which are not updated yet.


Yeah, Twitter required everyone to use OAuth, which these apps are using...just not getting to the page. Maybe it's something with urllib2...? Not sure why Gwibber's turning up a 401, it's the version from the sid repo...

-- Sent from my Palm Pre using Forums


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests