LMDE & VirtualBox Clone Issue [Solved...in a way]

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 16
Joined: Mon Jan 19, 2009 6:14 pm

LMDE & VirtualBox Clone Issue [Solved...in a way]

Postby zimbo » Mon Jun 06, 2011 5:49 pm

Last month I built myself a new PC and installed LMDE. I had been running LMDE on my old PC but decided to upgrade the hardware.

For the first time ever I have formatted my partitions with ext4 and am using kernel version 2.6.32-5-amd64.

I want to experiment with LMDE without breaking my main install so I installed VirtualBox 4.0.8 and created a LMDE 64bit guest machine. With all the updates installed on the guest machine I now want to clone it but this is where I am having problems.

Following the various guides I have found online I have tried the clonehd command

VBoxManage clonehd LMDE.vdi LMDE_clone.vdi

I have tried this command in various ways:
With and without LMDE.vdi being released in Virtual Media Manager.
With and without Virtual Box running, the LMDE virtual machine was switched off when VB was running.
Navigating to the folder where LMDE.vdi resides and running the command from there and also
running it with full path names.
Running the command as myself and also using sudo

Each time the result is always the same, the output from the command is

Clone hard disk created in format 'VDI'. UUID:

As you can see there is no new UUID created and when I look in the folder there is no clone file.

When watching the folder, while the command is running, a file appears with the LMDE_clone.vdi name but when the cloning is about 30% through the file disappears and the process jumps up to 100%.

I have tried copying the file in Nautilus, as myself and as superuser, but I get the error:
Error splicing file: Input/output error

I have also tried copying the file in the terminal, again as myself and as superuser, but get the error:
cp: reading `LMDE_VM.vdi': Input/output error

I don't know if the issue is with Virtual Box, the kernel or ext4, or a combination of them. Has anyone else experienced this problem?

Searching online the 'splicing file error' seems to occur with large file sizes, my file is 5.7GB. In some cases the problem has been down to the errors on the disks but mine is a brand new Samsung Spinpoint F3. I am not saying it isn't down to the hardware but I think unlikely, especially as the virtual machine boots and runs fine.
I found a Ubuntu thread where people have the same issue and the only solution is to use ddrescue.

There is a Peppermint thread where the problem is being experienced with PCManFM. In one post Kendall, the maintainer of LM LXDE and Fluxbox editions, says they are aware of the issue with LXDE and it is being worked on.

On a number of other threads I found the only way around has been to boot into Windows and create a copy of the file that way.

Is anyone able to help me with this issue?

As an experiment I booted my PC using a LM7 XFCE Live CD to see if I could copy the file under that Mint flavour. I mounted the ext4 partition but couldn't see any of the folders on the partition so wasn't able to attempt the copy.

I am wondering if I should re-install LMDE but format my partitions in ext3. Maybe I should create a virtual machine first to try it out.

Thanks for any help or guidance you can give me.

(Apologies for the long post)
Last edited by zimbo on Wed Jun 08, 2011 4:50 pm, edited 1 time in total.

User avatar
Level 1
Level 1
Posts: 26
Joined: Thu Apr 21, 2011 5:01 pm

Re: LMDE & VirtualBox Clone Issue

Postby chrisinspace » Tue Jun 07, 2011 9:06 am

Is your primary goal to create a copy of the existing VM? If so, you can export through the GUI. Just go to File --> Export. Give the file a name like LMDE2.ova. If you import it into the same installation of VirtualBox, it will give the machine an incremental name like LMDE_1 (you can always change that manually in the VM settings once the machine has been imported). The end result is a 2nd copy of the original VM.

Level 1
Level 1
Posts: 16
Joined: Mon Jan 19, 2009 6:14 pm

Re: LMDE & VirtualBox Clone Issue

Postby zimbo » Wed Jun 08, 2011 4:43 pm


Thanks for your reply. Yes, I was wanting to make a copy of my VM so that I had a backup I could revert to if I broke the other one. I have deleted the original VM saved on an ext4 partition so I am unable to try your suggestion to see if that works.

As an experiment I reformatted the partition I am keeping my VMs on, I formatted it to ext3, and created a new VM in that partition. I was then able to copy it in Nautilus and able to create a clone using the VBoxManage clonehd command.

There appears to be an issue with VBox and ext4 partitions, well there is on my PC. Anyway, I will now be keeping my VMs on an ext3 partition and am also considering converting all my data partitions to the ext3 format.

Level 4
Level 4
Posts: 274
Joined: Wed Jun 01, 2011 5:48 am

Re: LMDE & VirtualBox Clone Issue [Solved...in a way]

Postby roger64 » Fri Jun 10, 2011 9:27 am

I cannot confirm this ext4 issue because I did not try.

I have an ext3 partition where is my vdi named robot.vdi
I save it, from time to time, to an external disk on a ext4 partition.
I use the following command and gets a new uuid every time.

Code: Select all

VBoxManage clonevdi /voir/VirtualBox/VDI/robot.vdi /media/Premier/VB/robot.vdi

Return to “Archive”