PIdgin "Waiting for network connection" yet conn is ready

Archived topics about LMDE 1
Forum rules
mindmint
Level 1
Level 1
Posts: 37
Joined: Sun Jun 05, 2011 10:51 am

PIdgin "Waiting for network connection" yet conn is ready

Postby mindmint » Tue Jun 07, 2011 1:54 am

Bug report.
I have to disable the account and then re-enable it to get online. For each account.

PS: I found that after a long amount of time, or maybe in certain conditions it connects eventually. (I'm using Xfce.)
Last edited by mindmint on Wed Jun 08, 2011 3:02 pm, edited 1 time in total.

User avatar
karashata
Level 4
Level 4
Posts: 439
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada
Contact:

Re: PIdgin "Waiting for network connection" yet conn is read

Postby karashata » Wed Jun 08, 2011 2:56 pm

I'm experiencing this as well, on LMDE with GNOME 3. Before installing GNOME 3, Pidgin worked fine, and it also works fine in Mint 11 'Katya', so unfortunately I have no idea why it happens or how to fix it.

I'll admit, I didn't know about disabling and re-enabling the accounts being a valid workaround for the problem though, never thought to try that... I'll thank you for that, but it is only a workaround and not exactly ideal...
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image

Vermind
Level 1
Level 1
Posts: 16
Joined: Fri Aug 26, 2011 1:04 am

Re: PIdgin "Waiting for network connection" yet conn is read

Postby Vermind » Thu Sep 22, 2011 3:24 pm

My current workaround for this is compiling pidgin without network-manager support.
The following in a terminal should work:

Code: Select all

apt-get source pidgin
sudo apt-get build-dep pidgin
cd pidgin-2.10.0
gedit debian/rules

replace all instances of "enable-nm" with "disable-nm" and save. Finally,

Code: Select all

debuild

and wait 5-10 minutes and you should have pidgin built up. To install:

Code: Select all

cd ..
sudo dpkg -i pidgin_2.10.0-1_amd64.deb pidgin-data_2.10.0-1_all.deb


I hope it works for you too.

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: PIdgin "Waiting for network connection" yet conn is read

Postby zerozero » Thu Sep 22, 2011 4:21 pm

check this please viewtopic.php?f=198&t=67502&start=1180#p474556
it's not a solution, but solved it for me for now
Image

[ bliss of ignorance ]


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest