Skype looks ugly in LMDE x64

Archived topics about LMDE 1
Forum rules
User avatar
cdysthe
Level 3
Level 3
Posts: 111
Joined: Sun Oct 05, 2008 12:18 pm

Skype looks ugly in LMDE x64

Postby cdysthe » Wed Jul 20, 2011 4:13 pm

Hi,

Skype looks "ugly" in LMDE x64. It looks like the GTK theme isn't being applied. On LM 11 x64 Skype looks fine. I've noticed error messages when I start Skype from the command line:

Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
(<unknown>:3994): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64
(<unknown>:3994): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64
(<unknown>:3994): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
(<unknown>:3994): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64
(<unknown>:3994): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64
(<unknown>:3994): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
(<unknown>:3994): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64

Is it a way to fix this?

LifeInTheGrey
Level 3
Level 3
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Seattle
Contact:

Re: Skype looks ugly in LMDE x64

Postby LifeInTheGrey » Wed Jul 20, 2011 7:42 pm

I use Skype all of the time in two different LMDE setups and don't encounter a problem. Have you updated recently?
the beauty of linux is that the rabbit hole goes as deep as you want it to go.

wil
Level 1
Level 1
Posts: 28
Joined: Thu Apr 29, 2010 10:26 am

Re: Skype looks ugly in LMDE x64

Postby wil » Thu Jul 21, 2011 10:43 am

I use it on lmde64, no issues here. Well it crashes occasionally, but the UI is okay.

User avatar
cdysthe
Level 3
Level 3
Posts: 111
Joined: Sun Oct 05, 2008 12:18 pm

Re: Skype looks ugly in LMDE x64

Postby cdysthe » Thu Jul 21, 2011 10:46 pm

Hi.

Skype works fine, but the UI doesn't seem to be themed like it is on LM11. Buttons do not have rounded corners and the UI doesn't look as slick as it does on LM11. I'm pretty sure it has to do with ia32lib, but I'm not technical enough to know how to fix it.

josefg
Level 2
Level 2
Posts: 76
Joined: Sun Jun 12, 2011 7:07 pm

Re: Skype looks ugly in LMDE x64

Postby josefg » Mon Aug 01, 2011 5:35 pm

cdysthe wrote:Hi.

Skype works fine, but the UI doesn't seem to be themed like it is on LM11. Buttons do not have rounded corners and the UI doesn't look as slick as it does on LM11.


A workaround is to set a skin from inside skype itself, Options -> General -> Choose style, then pick CleanLooks or Plastique.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests