Get xmodmap to run automatically at Xserver startup [solved]

Archived topics about LMDE 1
Forum rules
Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Get xmodmap to run automatically at Xserver startup [solved]

Postby Brian49 » Sun Oct 09, 2011 2:54 pm

There have been a few forum threads here about issues with xmodmap, but not the particular issue that concerns me. Of course it isn't really specific to LMDE, but I just thought someone here might have figured it out. If so, I would be very glad of their assistance, please.

The issue is how to get xmodmap to run automatically at Xserver startup, so that my one-and-only keyboard tweak (to remap the CapsLock key) is ready and working by the time the desktop has loaded. There are numerous forum threads about this all over the Web, but most people still don't manage to get it fixed.

The usual advice is to create a file ~/.xmodmap containing the relevant commands, then put an entry in /etc/X11/xinit/xinitrc to ensure that the created file is read. But I find that this simply doesn't work. Nor does putting xmodmap, with those same commands, into the Application Autostart list. I know that the commands I'm using are correct because if I run them in a terminal they put the tweak into effect.

Until recently I was running LMDE Gnome, where there is an advanced keyboard options dialog for such tweaks. I'm now running LMDE Xfce, which sadly doesn't have that luxury. Many thanks for any kind help.

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: Get xmodmap to run automatically at Xserver startup [sol

Postby Brian49 » Mon Oct 10, 2011 4:24 pm

I haven't solved this directly, but I've found a different and easier way of achieving the same end result. It involves inserting the key-switch (caps:backspace) in the "xkboptions" line in the file /etc/default/keyboard. I can't swear that this is the best way, but it works.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests