strange home directory name change

Archived topics about LMDE 1
Forum rules
victorsk
Level 2
Level 2
Posts: 64
Joined: Fri May 07, 2010 12:28 am

strange home directory name change

Postby victorsk » Fri Dec 09, 2011 2:50 pm

Hi everyone,

I recently installed LMDE version on my new machine at work and I noticed a bizarre name change when I SSH to LMDE machine remotely. What happens is when I cd to my home directory, just type 'cd home', the name 'home' changes to 'hmee' :shock:

So, at the prompt it says: "victor hmee #"

if I pwd, I get the right name "/home", but at the prompt it says "hmee".

Has anyone noticed this? Is it some kind of a funny trick in this LMDE version?

Thanks,
Victor.

User avatar
xircon
Level 5
Level 5
Posts: 771
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: strange home directory name change

Postby xircon » Sat Dec 10, 2011 5:58 am

Yeh, I have occasionally noticed this in normal operations in a terminal as well. Don't know what causes it, but as you say pwd returns the correct info.

Cheers

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

scotte
Level 1
Level 1
Posts: 11
Joined: Wed Nov 02, 2011 7:15 pm

Re: strange home directory name change

Postby scotte » Mon Dec 12, 2011 12:13 am

What's your PS1 set to? I.e.:

Code: Select all

$ echo $PS1

victorsk
Level 2
Level 2
Posts: 64
Joined: Fri May 07, 2010 12:28 am

Re: strange home directory name change

Postby victorsk » Mon Dec 12, 2011 12:11 pm

scotte wrote:What's your PS1 set to? I.e.:

Code: Select all

$ echo $PS1


Hi I get this response:

Code: Select all

${debian_chroot:+($debian_chroot)}\[\033[01;31m\]\h\[\033[01;34m\] \W \$\[\033[00m\]


I have no idea what this means :?

EDIT:
------
Just to add, I also installed LMDE on my 32-bit laptop but the anomaly in question is not happening on my laptop. The 'echo $PS1' command on my laptop also gives the following:

Code: Select all

${debian_chroot:+($debian_chroot)}\[\033[01;31m\]\h\[\033[01;34m\] \W \$\[\033[00m\]


Which looks the same as the output on the machine with the problem. The machine with that strange home directory name is 64-bit, if that makes any difference.
Last edited by victorsk on Mon Dec 12, 2011 7:35 pm, edited 1 time in total.

User avatar
xircon
Level 5
Level 5
Posts: 771
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: strange home directory name change

Postby xircon » Mon Dec 12, 2011 12:36 pm

Code: Select all

${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[01;34m\] \w \$\[\033[00m\]


Similar but not identical (and just as mystical :))
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

scotte
Level 1
Level 1
Posts: 11
Joined: Wed Nov 02, 2011 7:15 pm

Re: strange home directory name change

Postby scotte » Tue Dec 13, 2011 2:01 am

PS1 is the prompt, and I wanted to see how it was configured. In neither case does it appear the prompt you are seeing is coming from PS1, which is curious. Both \w and \W are tokens for the directory name, but you should see '~' (tilde) when in your home directory, not 'home' (and certainly not 'hmee'!). Also, in the case for you victorsk, PS1 shows your prompt terminating with a '$', but your example shows a '#'! Very, very odd.

[EDIT] Ah-ha, here you go! http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=590052

victorsk
Level 2
Level 2
Posts: 64
Joined: Fri May 07, 2010 12:28 am

Re: strange home directory name change

Postby victorsk » Tue Dec 13, 2011 1:49 pm

Awesome! Thank you very much for the link, scotte. Now I can learn more about this problem :)


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 2 guests