Flash on firefox crashes GUI at random

Archived topics about LMDE 1
Forum rules
dascheer
Level 1
Level 1
Posts: 1
Joined: Mon Feb 20, 2012 2:13 pm

Flash on firefox crashes GUI at random

Postby dascheer » Mon Feb 20, 2012 2:22 pm

Hey Y'all.

This is my first LinuxMint post on the forums. I searched the forums for a similar topic but to no avail. Recent Ubuntu-to-LMDE convert, and I'm running Cinnamon on a 64-bit system.

I recently updated my system, which I remember included flash and firefox updates, and it seems that my GUI crashes at random whenever I play a video on youtube. I can't swtich into another tty or kill x to restart my session. I usually rely on those backdoors to troubleshoot bugs. The only solution is to unplug my laptop to power it off, which is unideal. I mostly use my laptop to look at videos, so this problem is driving me nuts. Any ideas? Thanks guys!

User avatar
xenopeek
Level 23
Level 23
Posts: 19017
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Flash on firefox crashes GUI at random

Postby xenopeek » Tue Feb 21, 2012 1:43 pm

Moved here by moderator
Image

ad1976
Level 1
Level 1
Posts: 10
Joined: Tue Feb 14, 2012 9:01 pm

Re: Flash on firefox crashes GUI at random

Postby ad1976 » Mon Mar 05, 2012 12:08 am

Hi there:

I am having the same problem. I hate Flash because is poorly supported for 64 bits, and for this reason is always a troublemaker.
Next time try to do this, before unplug your laptop:

http://kember.net/articles/reisub-the-g ... x-restart/

Monsta
Level 9
Level 9
Posts: 2911
Joined: Fri Aug 19, 2011 3:46 am

Re: Flash on firefox crashes GUI at random

Postby Monsta » Mon Mar 05, 2012 4:27 am

Try Flash-Aid extension. I can say it works fine on my LMDE x64. :)

User avatar
nomko
Level 10
Level 10
Posts: 3030
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Flash on firefox crashes GUI at random

Postby nomko » Mon Mar 05, 2012 4:34 am


Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: Flash on firefox crashes GUI at random

Postby Brian49 » Mon Mar 05, 2012 1:14 pm

I find that recent versions of Iceweasel (10 & 11) crash when I try to visit certain websites. I'm fairly sure that some issue with the Flash plugin is to blame, as sometimes the website opens OK if I whitelist it in my Flashblock preferences; but this doesn't always work. As far as I know, the installed Flash version is compatible with my system. I didn't get this problem with Iceweasel 9, which is no longer available in the repositories so I can't revert to it now.

Edit: Things improve when I re-enable the Firefox/Iceweasel plugin-container, which prevents the whole browser crashing if there is a problem with one or more plugins. I had disabled the container as it runs in a separate process, using quite a lot of extra memory.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest