Internal mic not working

Archived topics about LMDE 1
Forum rules
Karthikkeya
Level 1
Level 1
Posts: 26
Joined: Thu Jun 21, 2012 8:58 am

Internal mic not working

Postby Karthikkeya » Sun Jul 01, 2012 8:25 pm

Hello everyone!
I just installed LMDE 13 using Cinnamon desktop on my Acer Aspire One 150 laptop, model ZG5, and all hardware is working fine except that the internal mic is not working, it is not recording anything when I try *checked with pavu control, skype test call and cheese*.

I have been using different versions of ubuntu and linux mint, and the mic was working fine, but for some reason not in lmde 13.

I have done my best in troubleshooting:
put one of the channels down to zero and the other around 75%, didn't solve it (this solution worked in linux ubunut and linux mint).

I tried everything here...
http://wiki.debian.org/DebianAcerOne#Audio

plus i also noticed that the snd-pcsp module is not loaded, at least i can not see it in lsmod or lsmod | grep snd. anyhow, i still blacklisted it. also, since it has to do with the pc speaker, i blacklisted pcspkr module since i got beeping when shutting down the computer for instance, and that worked. yes, just to make it clear, the sound out works fine, but not the sound in.

anyone has any idea on how to solve this? would be nice not having to buy an external mic when i know it was working fine in an ubuntu based linux (and no, i don't want to switch back to ubuntu because it was freezing a lot, so i decided to switch to a stable linux distro!)

user@one ~ $ inxi -Fc 0
System: Host user@one Kernel 3.2.0-2-486 i686 (32 bit) Distro Linux Mint Debian Edition
CPU: Single core Intel Atom N270 (-UP-) cache 512 KB flags (sse sse2 sse3 ssse3) bmips 3191.71 clocked at 1600.00 MHz
Graphics: Card Intel Mobile 945GME Express Integrated Graphics Controller X.Org 1.11.4 Res: 1024x600@60.0hz
GLX Renderer Mesa DRI Intel 945GME x86/MMX/SSE2 GLX Version 1.4 Mesa 7.11.2 Direct Rendering Yes
Audio: Card Intel N10/ICH 7 Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
Sound: Advanced Linux Sound Architecture Version 1.0.24
Network: Card-1 Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver r8169 v: 2.3LK-NAPI at port 3000 BusID: 02:00.0
Card-2 Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) driver ath5k BusID: 03:00.0
Disks: HDD Total Size: 250.1GB (-) 1: /dev/sda WDC_WD2500BEVT 250.1GB
Partition: ID:/ size: 233G used: 23G (11%) fs: rootfs ID:/ size: 233G used: 23G (11%) fs: ext4
Sensors: System Temperatures: cpu: 59.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes 114 Uptime 48 min Memory 386.7/998.0MB Runlevel 2 Client Shell inxi 1.4.23

User avatar
Oscar799
Level 19
Level 19
Posts: 9440
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Internal mic not working

Postby Oscar799 » Mon Jul 02, 2012 8:03 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789

steve0
Level 1
Level 1
Posts: 22
Joined: Mon May 03, 2010 9:21 pm

Re: Internal mic not working

Postby steve0 » Wed Jul 18, 2012 12:09 pm

did you figure it out? I am having internal mic problems all of the sudden with my dell vostro..

Karthikkeya
Level 1
Level 1
Posts: 26
Joined: Thu Jun 21, 2012 8:58 am

Re: Internal mic not working

Postby Karthikkeya » Wed Jul 25, 2012 10:20 am

Nope, at the moment I´m stuck...

steve0
Level 1
Level 1
Posts: 22
Joined: Mon May 03, 2010 9:21 pm

Re: Internal mic not working

Postby steve0 » Wed Jul 25, 2012 10:29 am

got mine to work by fiddling with the alsamixer
terminal>alsamixer>F5 for all
use the arrows on your keyboard to move left and right and the up and down arrows to adjust the settings
good luck

Karthikkeya
Level 1
Level 1
Posts: 26
Joined: Thu Jun 21, 2012 8:58 am

Re: Internal mic not working

Postby Karthikkeya » Tue Sep 25, 2012 2:30 pm

Hello Linux Mint Forum, I have enjoyed Linux Mint a lot, but it just had to many bugs both for software and hardware, so I have switched to Linux EasyPeasy. With this distribution, everything works as it should for me. Who knows, if Linux Mint will get more stable, I might return?!

User avatar
Oscar799
Level 19
Level 19
Posts: 9440
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Internal mic not working

Postby Oscar799 » Tue Sep 25, 2012 5:00 pm

Karthikkeya wrote:Hello Linux Mint Forum, I have enjoyed Linux Mint a lot, but it just had to many bugs both for software and hardware, so I have switched to Linux EasyPeasy. With this distribution, everything works as it should for me. Who knows, if Linux Mint will get more stable, I might return?!


Please don't hijack other people's threads with offtopic posts
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests