ATI Radeon HD 3470 problems

Archived topics about LMDE 1
Forum rules
Helzaap
Level 1
Level 1
Posts: 1
Joined: Fri Jun 06, 2014 9:53 pm

ATI Radeon HD 3470 problems

Postby Helzaap » Fri Jun 06, 2014 10:09 pm

I don't know how to find LMDE How To for installing fglrx-legacy for my laptop on LMDE 201403 so I decided to write it to this thread. (Edit by admin: moved from viewtopic.php?f=59&t=168146 here.)

My laptop has ATI Radeon HD 3470.
This is what I've done. Nothing works, even some patching fails. This is a fruit of my work:

Code: Select all

m@l ~/Pulpit $ cd
m@l ~ $ cd Pobrane/ati/amd/
12.11/      12.9/       arch/       common/     packages/   setup.data/ xpic/       xpic_64a/   
m@l ~ $ cd Pobrane/ati/amd/
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-3.7.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-09-26 15:04:28.000000000 +0200
|+++ 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-10-16 20:30:42.146523753 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Hunk #1 succeeded at 3697 (offset -195 lines).
Hunk #2 succeeded at 3731 (offset -195 lines).
Hunk #3 succeeded at 3754 (offset -195 lines).
Hunk #4 succeeded at 3767 (offset -195 lines).
Hunk #5 succeeded at 3813 (offset -195 lines).
Hunk #6 succeeded at 3852 (offset -195 lines).
Hunk #7 succeeded at 3870 (offset -195 lines).
Hunk #8 succeeded at 3895 (offset -195 lines).
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-3.8.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 12.11/common/lib/modules/fglrx/build_mod/kcl_acpi.c   2012-10-23 22:44:52.000000000 +0200
|+++ 12.11/common/lib/modules/fglrx/build_mod/kcl_acpi.c   2012-12-22 22:11:30.289750331 +0100
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/kcl_acpi.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/kcl_acpi.c
m@l ~/Pobrane/ati/amd $ patch -p0 < ./3.5-do_mmap.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- a/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-06-15 18:30:13.483762070 +0200
|+++ b/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-06-17 17:47:36.543041869 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Hunk #1 succeeded at 2136 (offset 30 lines).
Hunk #2 succeeded at 2153 (offset 30 lines).
Hunk #3 succeeded at 2170 (offset 30 lines).
Hunk #4 succeeded at 2183 (offset 30 lines).
m@l ~/Pobrane/ati/amd $ patch -p0 < ./makefile_compat.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 10.10/common/lib/modules/fglrx/build_mod/2.6.x/Makefile   2010-09-22 09:15:33.000000000 +0200
|+++ 10.10/common/lib/modules/fglrx/build_mod/2.6.x/Makefile   2010-10-01 17:57:21.057820899 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/2.6.x/Makefile
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/2.6.x/Makefile
Hunk #1 succeeded at 68 (offset 2 lines).
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-authatieventsd.patch
bash: ./arch-fglrx-authatieventsd.patch: Nie ma takiego pliku ani katalogu
[1]m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-authatieventsd_new.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 14.1/common/etc/ati/authatieventsd.sh   2014-01-30 15:36:26.000000000 +0100
|+++ 14.1/common/etc/ati/authatieventsd.sh   2014-02-02 14:10:19.529653688 +0100
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/etc/ati/authatieventsd.sh
patching file /home/m/Pobrane/ati/amd/common/etc/ati/authatieventsd.sh
m@l ~/Pobrane/ati/amd $ rm -rf arch-fglrx-3.8.patch
m@l ~/Pobrane/ati/amd $ rm -rf 3.5-do_mmap.patch
m@l ~/Pobrane/ati/amd $ rm -rf makefile_compat.patch
m@l ~/Pobrane/ati/amd $ rm -rf arch-fglrx-authatieventsd_new.patch
m@l ~/Pobrane/ati/amd $ patch -p0 < ./lano1106_kcl_agp_13_4.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 13.4/common/lib/modules/fglrx/build_mod/kcl_agp.c   2013-05-24 16:45:52.236740084 -0400
|+++ 13.4/common/lib/modules/fglrx/build_mod/kcl_agp.c   2013-05-24 16:49:29.283579408 -0400
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/kcl_agp.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/kcl_agp.c
m@l ~/Pobrane/ati/amd $ rm -rf lano1106_kcl_agp_13_4.patch
m@l ~/Pobrane/ati/amd $ patch -p0 < ./lano1106_fglrx_intel_iommu.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-04-16 23:29:55.000000000 +0200
|+++ 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-05-21 17:05:34.726681102 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Hunk #1 succeeded at 93 with fuzz 2.
m@l ~/Pobrane/ati/amd $ rm -rf lano1106_fglrx_intel_iommu.patch
m@l ~/Pobrane/ati/amd $ patch -p0 < ./foutrelis_3.10_fix_for_legacy.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-04-16 23:29:55.000000000 +0200
|+++ 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-05-19 12:05:33.842076474 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patch unexpectedly ends in middle of line
Hunk #1 FAILED at 34.
1 out of 1 hunk FAILED -- saving rejects to file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c.rej
[1]m@l ~/Pobrane/ati/amd $
[1]m@l ~/Pobrane/ati/amd $ patch -p0 < ./foutrelis_3.10_fix_for_legacy.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-04-16 23:29:55.000000000 +0200
|+++ 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-05-19 12:05:33.842076474 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patch unexpectedly ends in middle of line
Hunk #1 FAILED at 34.
1 out of 1 hunk FAILED -- saving rejects to file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c.rej
[1]m@l ~/Pobrane/ati/amd $ sudo patch -p0 < ./foutrelis_3.10_fix_for_legacy.patch
[sudo] password for m:
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-04-16 23:29:55.000000000 +0200
|+++ 13.4/common/lib/modules/fglrx/build_mod/firegl_public.c   2013-05-19 12:05:33.842076474 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patch unexpectedly ends in middle of line
Hunk #1 FAILED at 34.
1 out of 1 hunk FAILED -- saving rejects to file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c.rej
[1]m@l ~/Pobrane/ati/amd $ rm -rf foutrelis_3.10_fix_for_legacy.patch
m@l ~/Pobrane/ati/amd $ patch -p0 < ./cold-fglrx-3.14-current_euid.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 14.1/common/lib/modules/fglrx/build_mod/firegl_public.c   2014-02-23 19:26:52.215995002 +0100
|+++ 14.1/common/lib/modules/fglrx/build_mod/firegl_public.c   2014-02-23 19:27:59.320999596 +0100
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Hunk #1 succeeded at 1555 with fuzz 2 (offset -206 lines).
m@l ~/Pobrane/ati/amd $ rm -rf cold-fglrx-3.14-current_euid.patch
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-3.7.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-09-26 15:04:28.000000000 +0200
|+++ 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-10-16 20:30:42.146523753 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Reversed (or previously applied) patch detected!  Assume -R? [n] 
Apply anyway? [n]
Skipping patch.
8 out of 8 hunks ignored -- saving rejects to file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c.rej
[1]m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-3.7.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-09-26 15:04:28.000000000 +0200
|+++ 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-10-16 20:30:42.146523753 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Reversed (or previously applied) patch detected!  Assume -R? [n] n
Apply anyway? [n] n
Skipping patch.
8 out of 8 hunks ignored -- saving rejects to file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c.rej
[1]m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-3.7.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-09-26 15:04:28.000000000 +0200
|+++ 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-10-16 20:30:42.146523753 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Reversed (or previously applied) patch detected!  Assume -R? [n] y
Hunk #1 succeeded at 3714 (offset -178 lines).
Hunk #2 succeeded at 3744 (offset -178 lines).
Hunk #3 succeeded at 3759 (offset -178 lines).
Hunk #4 succeeded at 3768 (offset -178 lines).
Hunk #5 succeeded at 3806 (offset -178 lines).
Hunk #6 succeeded at 3837 (offset -178 lines).
Hunk #7 succeeded at 3847 (offset -178 lines).
Hunk #8 succeeded at 3868 (offset -178 lines).
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-3.7.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-09-26 15:04:28.000000000 +0200
|+++ 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-10-16 20:30:42.146523753 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Hunk #1 succeeded at 3714 (offset -178 lines).
Hunk #2 succeeded at 3748 (offset -178 lines).
Hunk #3 succeeded at 3771 (offset -178 lines).
Hunk #4 succeeded at 3784 (offset -178 lines).
Hunk #5 succeeded at 3830 (offset -178 lines).
Hunk #6 succeeded at 3869 (offset -178 lines).
Hunk #7 succeeded at 3887 (offset -178 lines).
Hunk #8 succeeded at 3912 (offset -178 lines).
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch-fglrx-3.7.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-09-26 15:04:28.000000000 +0200
|+++ 12.9/common/lib/modules/fglrx/build_mod/firegl_public.c   2012-10-16 20:30:42.146523753 +0200
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/firegl_public.c
Reversed (or previously applied) patch detected!  Assume -R? [n] ^C
[130]m@l ~/Pobrane/ati/amd $ rm -rf arch-fglrx-3.7.patch
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch
arch/                             arch_3.13_kernel_acpi_node.patch 
m@l ~/Pobrane/ati/amd $ patch -p0 < ./arch_3.13_kernel_acpi_node.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- 13.11/common/lib/modules/fglrx/build_mod/kcl_acpi.c   2013-11-22 19:52:37.000000000 +0100
|+++ 13.11/common/lib/modules/fglrx/build_mod/kcl_acpi.c   2013-11-25 11:48:51.227678982 +0100
--------------------------
File to patch: /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/kcl_acpi.c     
patching file /home/m/Pobrane/ati/amd/common/lib/modules/fglrx/build_mod/kcl_acpi.c
Hunk #1 succeeded at 775 (offset -3 lines).
m@l ~/Pobrane/ati/amd $ sudo ./ati-
ati-installer.sh         ati-packager-helper.sh   ati-packager-wrapper.sh 
m@l ~/Pobrane/ati/amd $ sudo ./ati-installer.sh ^C
[130]m@l ~/Pobrane/ati/amd $ sudo ./ati-installer.sh 8.97.100.7 --install
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 6.9 or later 64-bit
loki_setup: directory: (null)
m@l ~/Pobrane/ati/amd $ sudo ./ati-installer.sh 8.97.100.7 --install
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 6.9 or later 64-bit
loki_setup: directory: (null)
m@l ~/Pobrane/ati/amd $ sudo ./ati-installer.sh 8.97.100.7 --install
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 6.9 or later 64-bit
loki_setup: directory: (null)
m@l ~/Pobrane/ati/amd $ sudo ./ati-installer.sh 8.97.100.7 --install
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 6.9 or later 64-bit
loki_setup: directory: (null)
DKMS part of installation failed.  Please refer to /usr/share/ati/fglrx-install.log for details

Any help would be appreciate!
I want to have this Linux mint system, cause its pretty and fast, but this drivers are killing me. I cannot install them. I have done I think everything possible by myself from this How To: https://wiki.debian.org/Installing_ATI_ ... est_kernel

Thanks!
Last edited by xenopeek on Sat Jun 07, 2014 1:17 am, edited 1 time in total.
Reason: fixed broken code tags, split from topic on main edition, moved to LMDE forum

jamaica
Level 1
Level 1
Posts: 6
Joined: Tue Apr 29, 2014 4:34 am

Re: ATI Radeon HD 3470 problems

Postby jamaica » Tue Jul 08, 2014 3:39 am

Maybe you should take a look at my guide on how to update the FGLRX driver via apt-pinning. Just replace the fglrx-* packages in the last step with the fglrx-legacy-* package names. This will install the latest driver from the debian unstable repository. For the legacy driver, this is 13.1. The following packages should be used in the last step:

Code: Select all

fglrx-legacy-atieventsd - events daemon for the non-free ATI/AMD RadeonHD display driver (legacy)
fglrx-legacy-control - control panel for the non-free ATI/AMD RadeonHD display driver (legacy)
fglrx-legacy-driver - non-free ATI/AMD RadeonHD display driver (legacy)
fglrx-legacy-modules-dkms - dkms module source for the non-free ATI/AMD RadeonHD display driver (legacy)
fglrx-legacy-source - kernel module source for the non-free ATI/AMD RadeonHD display driver (legacy)
libfglrx-legacy - non-free ATI/AMD RadeonHD display driver (runtime libraries) (legacy)
libfglrx-legacy-amdxvba1 - AMD XvBA (X-Video Bitstream Acceleration) runtime libraries (legacy)
libgl1-fglrx-legacy-glx - proprietary libGL for the non-free ATI/AMD RadeonHD display driver (legacy)


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests