install ati radeon proprietary driver

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 49
Joined: Thu Sep 16, 2010 2:30 pm

install ati radeon proprietary driver

Postby knireis » Wed Dec 29, 2010 6:55 am

How can i install the ati radeon proprietary driver for my 3450 graphics card in LMDE. I followed several instructions i found using google but none of them seem to work. In mint 10 based on ubuntu it is easy with help of the extra firmware option in the settings. Why is this not included in LMDE?
I need the 3D to work for using the flightgear simulator program.

User avatar
Level 4
Level 4
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: install ati radeon proprietary driver

Postby twa » Wed Dec 29, 2010 7:04 am


Driver video open source

This is the driver pre-installed in the system and it works with every VGA used: ATI/AMD,nVIDIA and Intel.

It is recommended if you do not want to install the proprietary drivers or if these are not campatible.
If your AMD/ATI model is NOT in the "HD series" category or an Intel graphic card, you can use only this driver; if you use an AMD/ATI in the "HD series" or nVIDIA, you can use the proprietary driver which is
usually more stable and performing of the Open drivers.

The Open driver does not need to be installed, and is disabled by default.
To activate it open Synaptic and search the package named: libgl1-mesa-dri
Doble click to install the package, then click on Apply.
Close Synaptic and reboot the system.
After the system has rebooted open the terminal and type:
glxinfo | grep render
if the output is similar to the image, the driver is active and working.

Proprietary nVIDIA Video Driver
If we want the maximum from our nVIDIA video card we must install the proprietary driver.
Open the terminal and type:
su -> password
apt-get install module-assistant
apt-get install nvidia-kernel-common
apt-get install nvidia-glx
apt-get install nvdia-kernel-source
apt-get install nvidia-xconfig
after the installation need to activate the driver from the same terminal by typing:
m-a prepare
m-a a-i nvidia
modprobe nvidia
Shut-down and reboot the PC
Verify if the driver has been successfully installed by typing from the terminal:
glxinfo | grep render

Proprietary ATI/AMD video driver
are available only for the more recent models, those in the "HD series"

The models NOT in the "HD series" can use only the Open driver.

For the "HD series" this is the procedure:
download the correct driver from here:
put the downloaded file in your Home and rename it " "
open the terminal and type: cd /home/yourusername
make the file executable by typing: sudo chmod a+rwx
execute the file by typing : sudo ./
follow the on-screen instructions till the end of the installation
activate the driver from the same terminal by typing : sudo aticonfig --initial -f
shutdown and reboot the system open the terminal and verify if the driver has been successfully installed
by typing : glxinfo | grep render
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.

Return to “Archive”