HP scanner works in LM 11 but not in LMDE or LMDE RC

Archived topics about LMDE 1
Forum rules
User avatar
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont

HP scanner works in LM 11 but not in LMDE or LMDE RC

Postby kmb42vt » Mon Sep 05, 2011 12:12 pm

I have an HP PSC 1410 All-in-one multifunction printer and scanner and I found out this morning that the scanner is not recognized although the printer works fine. These types of HP "all-in-one" multifunction units are some of the most common types available today and in the past and I found it a bit surprising that it wasn't fully supported out-of-the-box when it is fully supported in Linux Mint 11.

Anyway, the solution is to install 'libsane-hpaio' via Synaptic and then reboot. Now the scanner portion works fine. Since this package is included in Linux Mint 11 by default shouldn't it be included in LMDE by default as well?
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Level 2
Level 2
Posts: 56
Joined: Tue Jan 03, 2012 8:42 pm

Re: HP scanner works in LM 11 but not in LMDE or LMDE RC

Postby bdantas » Tue Apr 24, 2012 6:46 pm

I have a wireless HP Photosmart C8100 series and had a similar problem: Both printer and scanner worked in LM12, but only printer works in LMDE (UP4). My system does not detect a scanner on my network at all, so neither simple scan (simple-scan) or sane work. libsane-hpaio is installed.

I tried everything and went around in circle for hours. What finally fixed it for me was this:

1. sudo apt-get remove --purge hplip
2. manually installed hplip from the tarball available at the HP website (I followed the instructions for Debian 6.0+ 64-bit with the exception that I downloaded the dependencies listed for Linux Mint): http://hplipopensource.com/hplip-web/in ... ebian.html
3. sudo apt-get install libsane-hpaio (apparently this package got uninstalled at some point due to either step 1 or 2 above)

Now both printing and scanning works (I tried simple scan, which is the one I like. Xsane probably works, too, but I haven't tried it). I unchecked the HP System Tray Service from my Startup Applications, and still no problems. Solved :D

I agree with kmb42vt that the lack of out-of-the-box scanner LMDE support for my (presumably common) HP multifunction device is a bit surprising.

Level 1
Level 1
Posts: 41
Joined: Wed Apr 18, 2012 8:24 am

Re: HP scanner works in LM 11 but not in LMDE or LMDE RC

Postby toomuchcoffee » Wed Apr 25, 2012 9:54 pm

Under graphics there is simple scan.. and Xsane works great, bit overkill..
And HPLIP-GUI works, I was reluctant to install it because I thought it was only for KDE DE...

Code: Select all

The program 'suck' is currently not installed.  To run 'suck' please ask your administrator to install the package 'suck'

Return to “Archive”