Keyboard and mouse stop working after update

Archived topics about LMDE 1
Forum rules
blakeyed
Level 1
Level 1
Posts: 29
Joined: Wed Sep 07, 2011 1:49 am

Keyboard and mouse stop working after update

Postby blakeyed » Wed Sep 07, 2011 1:55 am

Hi!

I've just installed LMDE on my laptop. After install everything goes ok, and I update. I turn off my laptop and when I see the login screen, I can't use the keyboard or mouse :S

Anyone with the same problem? What could happen?

Thanks

User avatar
Gerd50
Level 5
Level 5
Posts: 734
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Keyboard and mouse stop working after update

Postby Gerd50 » Wed Sep 07, 2011 7:04 am

That could be a udev error. To fix it boot the recovery mode and run:

Code: Select all

telinit 5

You should have a working system now. Open the terminal and run:

Code: Select all

ls -l /etc/rc*.d/*udev*

If you get something like this:

Code: Select all

    # ls -l /etc/rc*.d/*udev*
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc0.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc0.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc1.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc1.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19 23. Aug 22:06 /etc/rc2.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 13. Sep 22:28 /etc/rc2.d/S02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc3.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc3.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc4.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc4.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 14 20. Sep 21:47 /etc/rc5.d/S02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19 20. Sep 23:33 /etc/rc5.d/S13udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc6.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc6.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 14 24. Feb 2010  /etc/rcS.d/S02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19 25. Feb 2010  /etc/rcS.d/S13udev-mtab -> ../init.d/udev-mtab

delete all the udev links from rc0 - rc6. Don't touch rcS.d, it's needed like it is.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1

blakeyed
Level 1
Level 1
Posts: 29
Joined: Wed Sep 07, 2011 1:49 am

Re: Keyboard and mouse stop working after update

Postby blakeyed » Thu Sep 08, 2011 2:50 pm

Thanks Gerd50 but the only udev and udev-mtab in /etc/rc*.d are in rcS.d.

Anyway I've noticed it's a bug in udev 171, when I plug in a keyboard it works well, udev doesn't add ID_INPUT tag to the device so Xorg can't detect which kind of device it is.

I'm blacklisting evdev module and loading it again in a while, just before X server start and it works well.

But that's just a workaround, I must update udev asap.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests