LMDE Epson Printer Problem

Archived topics about LMDE 1
Forum rules
bkovacs
Level 1
Level 1
Posts: 30
Joined: Thu Sep 22, 2011 1:47 pm

LMDE Epson Printer Problem

Postby bkovacs » Thu Sep 22, 2011 1:52 pm

I just installed LMDE Gnome yesterday and like it so far. But why is my Epson R340 not being detected. Usually every other Linux Mint distro as well as others seem to have no problem identifying and allowing me to set my R340 as default. Only thing it finds is PDF Printer.

bkovacs
Level 1
Level 1
Posts: 30
Joined: Thu Sep 22, 2011 1:47 pm

Re: LMDE Epson Printer Problem

Postby bkovacs » Fri Sep 30, 2011 2:22 am

Seems like some people are having problems with LMDE and Epson Printers. Like I stated in my previous post, my printer was not even recognized. works fine with Ubuntu 11.04 and Kubuntu 11.04. Any chance this will be fixed.

msm
Level 3
Level 3
Posts: 137
Joined: Tue Mar 23, 2010 7:40 am
Location: Dublin, Ireland

Re: LMDE Epson Printer Problem

Postby msm » Fri Sep 30, 2011 6:57 am

Did you check with Epson if they have any Debian drivers for their printers?

Edit: not sure, but try and see if one of the driver at the bottom of this page works: http://avasys.jp/eng/linux_driver/downl ... jet/escpr/

bkovacs
Level 1
Level 1
Posts: 30
Joined: Thu Sep 22, 2011 1:47 pm

Re: LMDE Epson Printer Problem

Postby bkovacs » Fri Sep 30, 2011 7:14 pm

Tried that page. Had driver installed, but still would not recognize printer. Seems like a bug in Debian somewhere. CentOS 6, Kubuntu 11.04, Fedora 15, all recognize printer.

bkovacs
Level 1
Level 1
Posts: 30
Joined: Thu Sep 22, 2011 1:47 pm

Re: LMDE Epson Printer Problem

Postby bkovacs » Thu Oct 20, 2011 9:22 pm

Well any other suggestions!!

pribina
Level 1
Level 1
Posts: 2
Joined: Sun Apr 24, 2011 5:17 am

Re: LMDE Epson Printer Problem

Postby pribina » Fri Oct 21, 2011 4:38 pm

My epson printer (SX105) seems to be working fine since the last update of a cups print server. Update your system and check if it is working now.

bkovacs
Level 1
Level 1
Posts: 30
Joined: Thu Sep 22, 2011 1:47 pm

Re: LMDE Epson Printer Problem

Postby bkovacs » Wed Oct 26, 2011 10:47 pm

Problem solved!!. Apparently Linux Kernel 3.0.0-12 was the problem. Launchpad has several users who encountered the same issue with this kernel. Updating to Kernel 3.0.0-13 solved the detection problem. So if you have a USB Epson Stylus printer that is not detected, than upgrade your Kernel to 3.0.0-13. Ubuntu 11.10 comes with Kernel 3.0.0-12 as default, if it had come with 3.0.0-13 than I wouldn't have had an issue. So check the 3.0...kernel version that Mint 11 and LMDE updates to. If 3.0.0-12 than avoid it. Go for 3.0.0-13.


Return to “Archive”

Who is online

Users browsing this forum: linux22 and 5 guests