64-bit printing problem

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 1
Joined: Sat Sep 24, 2011 8:15 pm

64-bit printing problem

Postby josephct3 » Sat Sep 24, 2011 9:29 pm

Hey folks,
I have a Lexmark X7675 wireless multifunction printer. I have been able to print to it wirelessly with 32-bit Debian, Ubuntu, and Mint, but I recently got a new 64-bit laptop. I have tried Mint Katya 64-bit on it, and was able to set up wireless printing by installing ia32-libs and openjdk-6-jre; getting the Lexmark 32-bit driver for my printer and running "./lexmark-08z-series-driver-1.0-1.i386.deb.sh --noexec --target lexmark"; then cd to lexmark and run "tar xvf instarchive_all --lzma"; then run "sudo dpkg -i --force-all lexmark-08z-series-driver-1.0-1.i386.deb". (Thanks to "_simon_" in Ubuntu forums.) Once I went through all this, I could set up the printer through "Control Center - Printing". Then printing worked fine.

I wanted to switch to LMDE, so I installed the 64-bit version with no problem. I followed the above procedure, assuming it would probably work. The Printing setup app sees the Lexmark, seems to set it up, but when I try to print a test page, I immediately get an error and the print job stops. I went to the trouble of reinstalling Katya 64-bit just to be sure printing would work, and printing worked fine. I reinstalled LMDE, followed the procedure again, but still no joy. It seems there is something different enough between the two distributions that causes a problem, but even with experimentation and with all the Googling and searching the Mint forums I've done, I can't find a solution.

Any ideas?



Level 1
Level 1
Posts: 2
Joined: Fri Jun 25, 2010 9:30 pm

Re: 64-bit printing problem

Postby dutch_kuykendall » Wed Mar 21, 2012 12:19 pm

Your problem is that Mint 11 (katya) is based on Ubuntu 11.04
If you read the documentation regarding the Lexmark printer drivers, it states that the drivers work for the following deban based systems:
Ubuntu 9.04
Ubuntu 9.10
Ubuntu 10.04
Ubuntu 10.10
Debian 6.0
Linux Mint 10
So Mint 11 is two new at this time. What difference this make, I have no clue.

Return to “Archive”