DVD drive not recognised

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 2
Joined: Tue Oct 04, 2011 3:56 am

DVD drive not recognised

Postby Silvo » Tue Oct 04, 2011 4:07 am


I recently installed LMDE, and just noticed today that my DVD drive doesn't work. Can't play a movie (in any application), can't burn, etc. I checked, and /dev/cdrom and /dev/dvd weren't created for me automatically, and symlinking them doesn't seem to help.

Should point out that the drive works fine in Windows and Ubuntu (where it is mounted as /dev/sr0 I believe -- in LMDE it appears to be at /dev/hda). I've tried googling this, and all I have found is that I can manually mount /dev/hda to somewhere like /mnt/cdrom and get a VIDEO_TS folder for my DVD, which is good. I also know that the DVD drive has been detected at some point, from this:

Code: Select all

cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:      hda
drive speed:      63
drive # of slots:   1
Can close tray:      1
Can open tray:      1
Can lock tray:      1
Can change speed:   1
Can select disk:   0
Can read multisession:   1
Can read MCN:      1
Reports media changed:   1
Can play audio:      1
Can write CD-R:      1
Can write CD-RW:   1
Can read DVD:      1
Can write DVD-R:   1
Can write DVD-RAM:   0
Can read MRW:      1
Can write MRW:      1
Can write RAM:      1

I also added my username to the audio and cdrom groups. Also, there are two blank folders: /media/cdrom and /media/cdrom0. They don't seem to do anything.

Can anyone help me here? I have no idea where to go from here. I'd like to be able to have all my programs automatically detect the drive so I can watch DVDs, burn CDs, without having to manually mount it every time.


P.S. and maybe when this is all solved, could anyone help explain why pressing eject on the drive will open and then immediately close the tray? Only happens in LMDE, not in Ubuntu or Windows.

User avatar
Level 4
Level 4
Posts: 350
Joined: Sat Jan 29, 2011 3:37 am

Re: DVD drive not recognised

Postby Beardedragon » Tue Oct 04, 2011 9:19 am

If you have VLC installed open it and in the top row menu go to Tools>Preferences and click on "Input & Codecs." Under "Default Optical Device" change from /dev/dvd to /dev/sr0 "Save" and this will solve the problem for this particular application.
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64

Level 1
Level 1
Posts: 2
Joined: Tue Oct 04, 2011 3:56 am

Re: DVD drive not recognised

Postby Silvo » Mon Oct 10, 2011 4:29 am


Thanks for your reply. However, I was hoping for a more permanent, system-wide solution.

Also, it didn't work. Choosing /dev/dvd, /dev/hda or /dev/sr0 as the DVD device in VLC fails with this error:

Playback failure:
DVDRead could not open the disc "/dev/xyz".

(where xyz is whichever device I chose).

Anyone have any other ideas?

Level 1
Level 1
Posts: 4
Joined: Mon Apr 11, 2011 2:26 pm

Re: DVD drive not recognised

Postby mnmnf » Fri Oct 14, 2011 6:35 am

I have the same problem on two different machines with LMDE xfce, Update Pack 3. One of which was working correctly before updating.

VLC does indeed work for me after changing default optical device to sr0.
But still can't read disks in any other application.

As posted elsewhere previously, installation of brasero-cdrkit has repaired Brasero for me.

Return to “Archive”