ASUS m5a78l-m lx3 Ethernet not working (driver problem?)

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 6
Joined: Tue Jan 22, 2013 3:05 am

ASUS m5a78l-m lx3 Ethernet not working (driver problem?)

Post by khanopus » Tue Apr 09, 2013 7:47 am

- Typed inxi -SN in terminal and it shows atheros8161
- Downloaded latest driver from link provided on previous post ... 08#p707208
- Tried to follow the commands posted
- Got lost in somewhere in between "sudo make install" because
nothing is happening.

The motherboard I am working on is an asus m5a78l-m lx3
Need some assistance. Please help

Level 1
Level 1
Posts: 2
Joined: Wed Apr 10, 2013 10:47 pm

Re: ASUS m5a78l-m lx3 Ethernet not working (driver problem?)

Post by edalbkrad » Wed Apr 10, 2013 11:03 pm

This issue is solved, khanopus was helping me with my motherboard.
I have included here what I did to install the lan driver so future users will know what to do.
These instructions in the other post did not work for me because it wasnt as detailed: ... 0&t=116490
If you try to run the script in the terminal (scripts/driver-select alx) it will say permission denied.
The driver should be in your home folder and not on any other folder or harddrive, you also have to use the terminal to extract the file.

If you have Atheros AR8161, follow these instructions:

1. download the driver here ... -u.tar.bz2

2. copy the downloaded file to home folder

3. go inside home folder, right click, open terminal

4. type these into the terminal:

tar -xvf compat-drivers-2013-03-04-u.tar.bz2
cd compat-drivers-2013-03-04-u
scripts/driver-select alx
sudo make install
sudo modprobe alx


Return to “LMDE 1 Archive”