trying to get asus n13 usb wireless adapter working.

Archived topics about LMDE 1
Forum rules
Ldv
Level 1
Level 1
Posts: 1
Joined: Thu Jul 07, 2011 6:50 am

trying to get asus n13 usb wireless adapter working.

Postby Ldv » Thu Jul 07, 2011 7:16 am

Hi,
I have a asus n13 wifi adapter and I am having trouble understanding the instructions for installing the driver(I don't know what I am doing).
The network that I am trying to connect to is hidden and WPA2 encrypted.

lsusb gives:
Bus 003 Device 002: ID 0930:0502 Toshiba Corp. Integrated Bluetooth
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0b05:1784 ASUSTek Computer, Inc. 802.11n Network Adapter
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

and iwconfig gives:
lo no wireless extensions.

eth1 no wireless extensions.

eth2 IEEE 802.11b ESSID:""
Mode:Managed Frequency:2.457 GHz Access Point: None
Bit Rate:11 Mb/s Sensitivity:1/0
Retry limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=66/70 Signal level=-36 dBm Noise level=-92 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

wlan0 Ralink STA ESSID:"" Nickname:"RT2870STA"
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=100/100 Signal level:-35 dBm Noise level:-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


I have followed the instructions in this post viewtopic.php?f=90&t=53153&start=0 up to the point where am i supposed to:
make
make install
sudo modprobe

I cannot find the WPA options(mentioned below) in the make file(in the post linked above), I do have the build-essential package. I also I don't know where the GCC and LD are.

"jcbaduk wrote:step3) define the GCC and LD of the target machine
define the compiler flags CFLAGS



I don't think you have to do anything...the config file looks just dandy to me, and has already enabled the WPA options.

You do already have the "build-essential" package, right? if so, you're ready to compile. "cd" into the "DPO_RT3070_LinuxSTA_V2.3.0.4_20100604" directory and proceed with"

I get the following output when I try to run make:

make -C tools
make[1]: Entering directory `/home/lawrence/2009_0811_RT3070_Linux_STA_v2.1.1.0_USB-N13/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/lawrence/2009_0811_RT3070_Linux_STA_v2.1.1.0_USB-N13/tools'
/home/lawrence/2009_0811_RT3070_Linux_STA_v2.1.1.0_USB-N13/tools/bin2h
cp -f os/linux/Makefile.6 /home/lawrence/2009_0811_RT3070_Linux_STA_v2.1.1.0_USB-N13/os/linux/Makefile
make -C /lib/modules//build SUBDIRS=/home/lawrence/2009_0811_RT3070_Linux_STA_v2.1.1.0_USB-N13/os/linux modules
make: *** /lib/modules//build: No such file or directory. Stop.
make: *** [LINUX] Error 2

So I am currently stuck(Googling the error gave me more information that I didn't understand).

I would really appreciate some help as I have been trying to get it to work for about a week now.
The adapter has connected once while running LMDE, twice while running crunchbang linux(debian based) and works with windows.

AlbertP
Level 16
Level 16
Posts: 6707
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: trying to get asus n13 usb wireless adapter working.

Postby AlbertP » Thu Jul 07, 2011 7:41 am

Probably it helps to un-hide the network for a while, then connect and set-up automatic connection, and then hide it again.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 4 guests