Wireless not working on laptop[SOLVED]

Archived topics about LMDE 1
Forum rules
kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Wireless not working on laptop[SOLVED]

Postby kbkb » Sat Sep 03, 2011 12:44 pm

Hi,

My laptop uses the following wireless card:
Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
I've gotten that information from using:

Code: Select all

lspci -v
in terminal

Unfortunately the network manager states that "Wireless is disabled".
As a result I can't connect via wireless.

Can someone help me?
Last edited by kbkb on Sun Sep 04, 2011 10:53 am, edited 1 time in total.

kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Re: Wireless not working on laptop

Postby kbkb » Sun Sep 04, 2011 10:23 am

My problem has been solved, my Compaq Presario CQ60 now has wireless capability.

Using the Software Repository, I installed rfkill.
I then entered the following in terminal:

Code: Select all

sudo rfkill unblock 0
sudo rfkill unblock 1
ifconfig wlan0 up


Credit goes to: http://axcoto.com/blog/article/tag/sioc ... to-rf-kill

This fix is not permanent. To make it permanent, I created /bin/wlan and placed the following in it:

Code: Select all

#! /bin/bash
sudo rfkill unblock 0
sudo rfkill unblock 1
ifconfig wlan0 up


I made it executable and then added an entry in rc.local

Code: Select all

/bin/wlan


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests