Ad-hoc Mint network not handing out IP addresses

Archived topics about LMDE 1
Forum rules
dharhpk
Level 1
Level 1
Posts: 1
Joined: Mon Nov 28, 2011 10:16 am

Ad-hoc Mint network not handing out IP addresses

Postby dharhpk » Mon Nov 28, 2011 10:32 am

I'm trying to set up an ad-hoc wifi network so I can share my Mint laptop's wired connection with my iPhone (thus getting around a port block on a work network).

I've followed the various HOWTO guides on setting up an ad-hoc network and got that working -- I can set it up on Mint, see it on my iPhone, select it, get asked a WEP password, it's all great. EXCEPT...Mint isn't giving me an IP address, gateway, etc.

I've got this working before on Ubuntu, but for the life of me can't get it working under LMDE! I've removed dnsmasq (going with dnsmasq-base instead) and in general, followed the instructions at https://help.ubuntu.com/community/Internet/ConnectionSharing.

Can anyone help me kick DHCP into motion? Thanks!

-g.

Michael Ellis
Level 1
Level 1
Posts: 1
Joined: Mon Nov 28, 2011 12:36 pm

Re: Ad-hoc Mint network not handing out IP addresses

Postby Michael Ellis » Mon Nov 28, 2011 12:55 pm

I'm encountering a similar issue trying to set up an autostart-able ad hoc connection over wireless on Linux Mint 10. We have a number of headless (no kbd/mouse/monitor) monitoring systems in the field and I'm trying to make it possible for our techs to connect locally without having to bring a keyboard/monitor combo.

I've got the ad-hoc service mostly working using nothing but the standard GUI config options but can't get it to autostart after a reboot.

Any help appreciated and if I figure it out on my own I'll share it here.

Cheers,
Mike


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests