NFS Not Mounting

Archived topics about LMDE 1
Forum rules
kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

NFS Not Mounting

Postby kbkb » Fri Sep 17, 2010 11:53 pm

Hi,

I have a NFS network setup for three systems.
The exports file is the same for all systems: /home 192.168.0.0/255.255.255.0(rw,async)
My rounter is configured for static IPS.

The fstab file contains the following (3 systems):
#System kendan 192.168.0.100
192.168.0.101:/home /mnt/home_peppermint nfs rw,auto,async
192.168.0.105:/home /mnt/home_bubblegum nfs rw,auto,async

#System bubblegum 192.168.0.105
192.168.0.100:/home /mnt/home_kendan nfs rw,auto,async
192.168.0.101:/home /mnt/home_peppermint nfs rw,auto,async

#System peppermint 192.168.0.101
192.168.0.100:/home /mnt/home_kendan nfs rw,auto,async
192.168.0.105:/home /mnt/home_bubblegum nfs rw,auto,async

When I was using Linux Mint 9, I had no problems. I have been using LMDE since the launch on two systems. Yesterday I've noticed that the folders are not being mounted on either LMDE system. The test computers which I am about to speak of below are about two computers only (kendan & bubblegum).

I rebooted both systems. The mounts did not occur. I had to manually type in sudo mount -a to get it to work. I've been doing some research on this. What changed since two days ago? In addition, system bubblegum did not mount the folder in kendan even with the sudo mount -a command. Some people suggest using a sleep method in rc.local. Is the the best way to handle this? If so, where is rc.local? Is there a method that when the /mnt/home_kendan folder (example) is accessed then it will do an auto mount if it is not available?

Thanks,

Ken

altair4
Level 17
Level 17
Posts: 7900
Joined: Tue Feb 03, 2009 10:27 am

Re: NFS Not Mounting

Postby altair4 » Sat Sep 18, 2010 7:40 am

There is a similar problem when using classic samba mounts in fstab. The instructions in fstab are being executed before the network is up so they fail. One way around this is to create a script ( mount -a ) that will execute only after the network is up and running:

Create a script:

Code: Select all

gksu gedit /etc/network/if-up.d/fstab

With this content:

Code: Select all

#!/bin/sh
mount -a

Save the file, exit gedit, and back in the terminal make the file executable:

Code: Select all

sudo chmod +x /etc/network/if-up.d/fstab

Any script placed in if-up.d will execute only after the network is up.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Re: NFS Not Mounting

Postby kbkb » Sat Sep 18, 2010 11:35 am

Hi,

That did the trick for bubblegum, but I still have issues with kendan.
I did verify the file that was created. It's good.

At this point kendan did not mount bubblegume's home folder.
I then issues on the kendan and observed the results on terminal :

sudo mount -a #terminal hung
I performed a ctrl-c #I have the terminal back and so I checked to see if the folder was mounted - no
sudo mount -a #terminal hung. I waited then I got "mount.nfs:mount system call failed. I checked to see if bubblegum was mounted - YES (odd)"

I rebooted kendan
bubblegum home folder was not mounted
sudo mount -a #Hung
I performed a ctrl-c # I hae the terminal back and so I checked to see if bubblegum (home) was mounted - YES (odd again)

In kendan I performed a sudo mount -f and here are the results (bubblegum is mounted at this time)
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sr0 on /media/cdrom0 type udf (ro,noexec,nosuid,nodev,user=kendan)
192.168.0.105:/home on /mnt/home_bubblegum type nfs (rw,addr=192.168.0.105)

Ideas?

kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Re: NFS Not Mounting

Postby kbkb » Sat Sep 25, 2010 7:08 pm

Bump...

Any ideas. Sometimes when I boot up it works. Sometimes it does not.
*Unreliable*

When I type sudo mount -a in the terminal it often hangs.

kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Re: NFS Not Mounting

Postby kbkb » Sun Sep 26, 2010 8:27 pm

Hi,

Is there anyone else having issues with LMDE and NFS? Am I the only one?

Why is it that my terminal hangs when I type sudo mount -a #(not all the time)?
Is there anything I can do to make it reliable? Am I waiting for a patch to come down?

Your help would be very appreciative.

Ken

User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: NFS Not Mounting

Postby zombie » Sun Sep 26, 2010 10:04 pm

Just a shot in the dark:
Check that NFS is added to /etc/modules

kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Re: NFS Not Mounting

Postby kbkb » Sun Sep 26, 2010 10:56 pm

Hi,

Thank you for contacting me.

Here is the contents of my modules file:

Code: Select all

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

loop


What would you suggest that I put in it?

User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: NFS Not Mounting

Postby zombie » Sun Sep 26, 2010 11:41 pm

Put "nfs" on the line under "loop".

I don't know if this is required with NFS v3. I am using NFS v4 and it is required then.

kbkb
Level 2
Level 2
Posts: 55
Joined: Sat Jul 31, 2010 9:32 am

Re: NFS Not Mounting

Postby kbkb » Mon Sep 27, 2010 5:43 pm

Code: Select all

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

loop
nfs


I did this to two systems. It didn't work.

MountainX
Level 1
Level 1
Posts: 47
Joined: Fri Jul 02, 2010 10:36 pm

Re: NFS Not Mounting

Postby MountainX » Wed Oct 06, 2010 1:27 pm

I am having a nearly identical problem. My home NFS server is running Ubuntu 8.04 LTS. I have several clients connected to it and all work well. But I cannot get my Linux Mint 9 machine to connect. I _can_ connect from an identical computer that is running Ubuntu 10.04. The NFS client configuration is the same on both.

On the Linux Mint 9 box, when I try to manually mount, I get this error:
mount.nfs:mount system call failed

BrainwreckedTech
Level 1
Level 1
Posts: 1
Joined: Sun May 15, 2011 2:48 am

Re: NFS Not Mounting

Postby BrainwreckedTech » Mon May 16, 2011 6:19 pm

Had this problem too, where NFS entries in /etc/fstab weren't being automatically mounted at boot time but a manual mount-a worked,

if-up.d didn't work for me. Neither did the post-up command in /etc/network/interfaces. I notice rpcbind is complaining about something during startup but the text goes by too fast to see much of anything.

My first solution was to edit /etc/init.d/gdm3 and stick the mount -a command in there as the first executed command, knowing that gdm3 is one of the last-called scripts.

Today I found a better way -- use /etc/rc.local which states that is executed at the end of each multi-user level, which I take to mean after everything in /etc/rc[2-5].d

It's not The Debian Way (TM) (according to its FAQ on the matter of SysV init, last updated in 2009) but it's working for this and for setting custom CPUFreq OnDemand up_thresholds.


Return to “Archive”

Who is online

Users browsing this forum: Google [Bot] and 0 guests