Recovery mode - internet connection

Archived topics about LMDE 1
Forum rules
Level 3
Level 3
Posts: 154
Joined: Sun Jul 20, 2008 8:46 am

Recovery mode - internet connection

Postby madwoollything » Mon Apr 18, 2011 5:52 am

My system is broken and I thought I'd try to ensure that all updates have been installed but I don't know how to get a working internet connection when in recovery mode in LMDE.

(I'd really like to try and recover my system and re-installing will probably just end up in the same 'lock-up' when the updates are applied.)

How do I get a working internet connection in LMDE Recovery mode??

Level 4
Level 4
Posts: 370
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Recovery mode - internet connection

Postby cecar » Mon Apr 18, 2011 6:27 am

Have you tried to delete the xorg.conf file? I usually can get to the desktop if i do that and install the graphic driver.

Code: Select all

rm /etc/X11/xorg.conf

Sorry. Apperently you have tried that... Didnt see that at first..

Level 5
Level 5
Posts: 500
Joined: Thu Nov 27, 2008 9:38 pm

Re: Recovery mode - internet connection

Postby rdonnelly » Mon Apr 18, 2011 6:48 am

You could try to reinstall and remove testing from the repos before you update, I have not been able to get my system to work properly at all since the last week of updates. I am running a restored clonezilla clone from early April and I have not updated to Mintsystem7.7.5 either, that has been causing all kinds of problems. You will not have the latest and greatest, but your system will work. It is just one of the pitfalls of Debian, you should get Clonezilla and clone your partitions, you can restore / with 5 or 6 GB in about 2 minutes compared to a reinstall of 30 minutes, plus getting all the packages reinstalled, and if you wipe home, alot more work.
Using Mint since 2008
*Mint 18.2 KDE
*ASUS 970 PRO GAMING/AURA AM3+ AMD 970 + SB 950 SATA 6Gb/s USB 3.1
*AMD FX-8370 with AMD Wraith cooler Vishera 8-Core 4.0 GHz (4.3 GHz Turbo)
*G.SKILL Ripjaws X Series 16GB DDR3 SDRAM

Level 3
Level 3
Posts: 170
Joined: Fri Sep 10, 2010 11:39 am
Location: Spokane Wash, USA

Re: Recovery mode - internet connection

Postby CiaW » Mon Apr 18, 2011 11:24 am

I booted to rescue mode once and thought that internet was working, but I'm not positive. At any rate, if you're using wired ethernet connection, you can try 'ifup eth0' or, for some reason my system has it as eth1 so you would use 'ifup eth1' if 0 doesn't work (don't type the quotes). Or if you're using wireless use 'ifup wlan0' -- but then if it wants a wireless password I'm not positive the command to enter that, you could check the man pages for ifup or perhaps someone else knows, or you could temporarily shut off the security. Please advise if it is wireless and you need that information.

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest