Audio device gone after suspend

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 29
Joined: Wed Aug 01, 2012 5:46 pm

Audio device gone after suspend

Postby Zyzz » Tue Apr 15, 2014 12:37 pm

Hi there,

my USB Audio (speakers) is gone after I wake my PC from suspend. Only a reboot helps getting it back. (Or unplugging and plgging them again does it too but that's not long term solution either.)
It's not listed under pulseaudio volume manager nor in alsamixer.
The worst is that my music is then playing on my headphones and it's very loud (I can hear the music playing without having them on my head), so I fear it might damage them in the long run.

It also doesn't appear to happen every time maybe 50% of the time.

Is there a certain log where I could check what may happen when it's gone? Is suspend deactivating the usb devices?

Maybe it's the storage the speakers have. They seem to have drivers on them for windows.It also is plugged in USB 3.0. (I can't use USB 2.0 as if I have legacy support activated it tries reading this storage and makes the bootup take 2-3 minutes whereas I need legacy support for my keyboard. In short legacy for 2.0 but not 3.0.)

I'm using/running:
LMDE (Cinnamon)
USB Speakers from Edifier on USB 3.0
Creative Audigy 2 ZS as main soundcard for my headphones

Let me know if you need to know something specific. :)

Level 1
Level 1
Posts: 1
Joined: Thu Nov 13, 2014 3:29 pm

Re: Audio device gone after suspend

Postby thestagemanager » Thu Nov 13, 2014 3:31 pm

I'm seeing this behavior as well, running Mint 17 MATE. Have you, or anyone else, found a fix to this problem yet?

User avatar
Level 19
Level 19
Posts: 9441
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Audio device gone after suspend

Postby Oscar799 » Sat Nov 29, 2014 12:25 pm

Please don't add questions about Main edition to threads about LMDE
Please start a new thread here instead viewforum.php?f=48
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 13 guests