Sony E Series VPCEC309X Sound

Archived topics about LMDE 1
Forum rules
rodneyck
Level 1
Level 1
Posts: 2
Joined: Thu Jan 20, 2011 3:55 pm

Sony E Series VPCEC309X Sound

Postby rodneyck » Thu Jan 20, 2011 4:06 pm

Hi Everyone,

Wanted to say I love the new LMDE 64bit! I received my new custom built Sony laptop and in the event other users are having issues with the getting LMDE's sound to work, I would thought I would pass these helpful hints along.

The only kernel I could get the sound to work under was the Liquorix kernel which you can get by using SMXI, download scripts at smxi.org. Go through the steps of adding the Liquorix kernels to your source.lst. Use the Linux 2.6.34-2.dmz.3-liquorix-amd64 kernel. There is a 2.6.35 Liquorix version, but I have found that that ATI proprietary video card drivers do not work with this kernel yet, so stick with the .34 kernel.

It is great to have everything working under LMDE.

The only other issue I had with my Sony and LMDE was the trackpad. I will post the steps to get this working later.

Best,
R

rodneyck
Level 1
Level 1
Posts: 2
Joined: Thu Jan 20, 2011 3:55 pm

Re: Sony E Series VPCEC309X Sound

Postby rodneyck » Sun Jan 23, 2011 3:56 pm

To get the trackpad working on the Sony E series, you may need to do the following;

1. edit the file /etc/default/grub
2. Change the following line; GRUB_CMDLINE_LINUX=""
3. to; GRUB_CMDLINE_LINUX="i8042.nopnp"
4. After the edit, open up a terminal and run; sudo update-grub.
5. reboot


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 8 guests