Multiple flash installs

Archived topics about LMDE 1
Forum rules
rtrev
Level 3
Level 3
Posts: 111
Joined: Fri Oct 15, 2010 11:11 am

Multiple flash installs

Postby rtrev » Tue Aug 02, 2011 11:03 am

I'm using LMDE 64-bit, "Latest" repositories, with Google Chrome (unstable) as the browser.

When I go to about:plugins, it shows me two installations of flash being used.

One is:

/opt/mint-flashplugin-x64/libflashplayer.so

And the other is:

/usr/lib/flashplugin-nonfree/libflashplayer.so

Both of these have the option to disable them, leading me to think that they are, in fact, distinct installs of flash which are both somehow "in use".

Now the puzzling thing is that Google Chrome is supposed to bring along it's *own* copy of flash, but I don't see that one (I think it's usually in the Chrome directory.)

Another odd thing is that in Synaptic it shows the mint-flashplugin-x64 as "Installed local or obsolete".

Can anybody suggest the appropriate course of action here? I don't know if perhaps Chrome no longer ships it's own flash, and I have no idea why there's a mint version of flash, or if it's really obsolete, etc. A bit confused! :wink:

Thanks,
Bob

User avatar
wyrdoak
Level 6
Level 6
Posts: 1309
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Multiple flash installs

Postby wyrdoak » Tue Aug 02, 2011 12:34 pm

/usr/lib/flashplugin-nonfree/libflashplayer.so

Is were flash works in Chrome amd64 any place else IMHO is just a waste and causing the correct one not to work.

Go here: http://labs.adobe.com/downloads/flashplayer11.html

unpack the libflashplayer.so and replace the one in the above location with the one you downloaded.

then do a system search for libflashplayer.so and replace them all with the one you downloaded or delete the others.

Flash player 11 beta is the only one I've found to work I'm running the latest Chrome 14.
-Dell Mini Inspiron 910 Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(LinixMint-17.1: KDE)

rtrev
Level 3
Level 3
Posts: 111
Joined: Fri Oct 15, 2010 11:11 am

Re: Multiple flash installs

Postby rtrev » Tue Aug 02, 2011 12:55 pm

Thanks. I didn't even know there was a beta 11 available.

Before you replied, I did try installing the /opt/mint-flashplugin-square/libflashplayer.so and that seems to work with latest Chrome 14 also. All of the other libflashplayer.so files on the system seem to be symbolic links to this one now. Hmm.

User avatar
wyrdoak
Level 6
Level 6
Posts: 1309
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Multiple flash installs

Postby wyrdoak » Tue Aug 02, 2011 1:34 pm

I might still have Window$ on the brain but it seems to me have different versions on the same machine causes a conflict. I just changed them all to the same version not knowing why the other files are there.
-Dell Mini Inspiron 910 Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(LinixMint-17.1: KDE)


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 4 guests