Archived topics about LMDE 1 and LMDE 2
Level 1
Level 1
Posts: 31
Joined: Sat Nov 06, 2010 11:39 pm


Post by nevius »

The follow are the steps I used to install and configure LMDE on a MacBook 4.1 (mid-2008) and dual boot it with OS-X (all of this information is shamelessly lifted from various websites):

Install rEFIt in OS-X
Download rEFIt from here:
Install rEFIt and make sure it is working (you should get a boot chooser on startup)
Use Bootcamp or Disk Utility to create a partition at the end of the disc. Don’t worry about what format, just make it the size you want for LMDE and your swap partition.

Install LMDE from the Live DVD
Boot the LMDE Live DVD. Use gparted to delete the partition you just made in OS X. It should be the last partition on the disc and follows after the HFS+ partition (OS X). Deleting it will leave an area called unallocated. This is free space, and exactly what you want. Use gparted to manually partition the space on your drive for Ubuntu. First create a SWAP area of about 1GB. Then the rest of the unallocated area format as EXT4. Apply changes and take note the label of the EXT4 partition such as /dev/sda3.

Start the LMDE Installer from the desktop icon. When prompted, choose to manually partition. Select the EXT4 partition and click change. Select to use the space as EXT4 and root (/) as the mount point. You will also want to check the box to format the partition.

At the end of the installation process, the installer will ask you where you want to install GRUB. The standard location is the MBR (SDA) do not install GRUB in the MBR. Install it on my main LMDE partition (SDA3).

Reboot when done with the install, and in the rEFIt menu, choose the partition tool. It will attempt to sync the partition tables on your disk. Then SHUTDOWN the computer (not reboot), and start it again. You should be able to boot to LMDE now. If it seems to freeze on the tux logo, completely shutdown again and try one more time.

Configuration Tips
Wireless cards can vary between MacBook models. The MacBook 4.1 uses a broadcom BCM4321 wireless card. It did not work out of the box. The following guide provides a procedure for installing / configuring the broadcom wireless driver:

The MacBook runs hot. This can be easily fixed by installing and configuring macfanctrld from the Ubuntu Mactel Support PPA:

The iSight camera will also not work out of the box. You need to run "isight-firmware-tools", but if you are using Snow Leopard, the version of isight-firmware-tools in the repositories (1.4.2) will not work. You need to get 1.5.92 from the Ubuntu Mactel Support PPA. Before you install this package you need to mount the OS-X drive in LMDE

Code: Select all

sudo mkdir /MacOSX
sudo mount -t hfsplus /dev/sda2 /MacOSX
You will need to reboot the MacBook after the firmware has been extracted.

These are some pretty barebones instructions. My sources for this information are as follows: ... stallation ... /+packages ... ppleiSight

Hope this helps.

Level 1
Level 1
Posts: 21
Joined: Sat Sep 17, 2011 12:35 pm


Post by untmdsprt »

I have a few additions to make if you're using the new Lion OS.

Lion adds a "recovery HD" in addition to the main drive, so in order to add a partition for Linux, you have to use Disk Utility. Warning: You must boot from your internal drive first. Go into the app and then go to the partition tab. Click on the "+" to add more partitions to your drive. Make sure you have the total size you want for the Mac and the Linux sides before you click "apply". Once you click apply, you're stuck as the OS will safely create the partitions and then move the recovery drive.

You can use rEFIt, but it has to be installed manually in Lion. Follow directions on the website. GRUB still needs to be installed to the Linux boot partition. In this case, it will be sda4 as sda3 will now be the recovery HD. Please take care before you install.

Continue following the directions as posted by nevius.

Level 1
Level 1
Posts: 1
Joined: Sun Dec 25, 2011 3:02 pm


Post by Zarathustra2 »

Why does this not work for me?

I have a MacBookPro 5,3 (Late 09) installed rEFlt and created a Linux USB Stick (dd if=/Users/Zarathustra/Downloads/linuxmint-201109-gnome-dvd-64bit.iso of=/dev/disk1 bs=1m)

And now I try to boot while pressing the option key i can choose rEFlt & the Recovery HD but there is no Linux to choose. Why?

And i also have a 80 GB empty partition actually formated in FAT. (but I think that here dose't matter)

So what am I doing wrong?

Level 1
Level 1
Posts: 3
Joined: Thu Nov 17, 2011 11:36 pm


Post by terroreek »

When I installed LMDE on my macbook I had to install grub to /dev/sda and not /dev/sda3 to get grub working, as far I know that's not right but it worked, without overwriting refit.

If anyone wants to get their little mac remote working in LMDE install lirc,

Code: Select all

sudo apt-get install lirc
You'll get an error about an invalid /etc/lirc/lircd.conf file, just ignore that and backup and edit the /etc/lirc/hardware.conf file and replace it with this.

Code: Select all

# /etc/lirc/hardware.conf
# Arguments which will be used when launching lircd

#Don't start lircmd even if there seems to be a good config file

#Don't start irexec, even if a good config file seems to exist.

#Try to load appropriate kernel modules

# Run "lircd --driver=help" for a list of supported drivers.
# usually /dev/lirc0 is the correct setting for systems using udev 

# Default configuration files for your hardware if any
All we are changing is using the macmini driver and pointing to the hiddev0 device.

Now backup and edit the /etc/lirc/lircd.conf file and replace the file with;

Code: Select all

# this config file was automatically generated
# using lirc-0.8.2(macmini) on Tue Dec 11 11:35:26 2007
# contributed by Sebastian Schaetzel 
# brand:                       Apple
# model no. of remote control: A1156
# devices being controlled by this remote: Mac mini, MacBookPro 15"
# SantaRosa (3.1), MacBook2

begin remote

  name  Apple_A1156
  bits            8
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  pre_data_bits   24
  pre_data       0x87EE81
  gap          211982
  toggle_bit_mask 0x0
  ignore_mask 0x0000ff01

      begin codes
          KEY_VOLUMEUP		0x0B
          KEY_VOLUMEDOWN	0x0D
          KEY_REWIND		0x08
          KEY_FORWARD		0x07
          KEY_PLAYPAUSE		0x04
          KEY_MENU		0x02
      end codes

end remote 
now start lirc,

Code: Select all

sudo /etc/init.d/lirc start
In terminal, type in irw and press the buttons on your remote you should get outputs like this;

Code: Select all

0000000087ee8102 00 KEY_MENU Apple_A1156
0000000087ee810d 00 KEY_VOLUMEDOWN Apple_A1156
0000000087ee810b 00 KEY_VOLUMEUP Apple_A1156
0000000087ee8108 00 KEY_REWIND Apple_A1156
0000000087ee8107 00 KEY_FORWARD Apple_A1156
0000000087ee8104 00 KEY_PLAYPAUSE Apple_A1156
Now you just need to configure your .lircrc file for your applications.

Level 1
Level 1
Posts: 12
Joined: Fri Nov 16, 2012 3:44 pm


Post by cj123 »

Quick note of a problem I had with installation and a solution found elsewhere on the Mint forum. It spent a lot of time searching before finding a fix at the bottom of page 3 here:

I just installed LMDE on a 2008 macbook 3,1. I followed the installation process here and had to abort because I was not given the option of installing the bootloader in my Mint partition (sda3). The same thing happened to me when I tried to install Debian. You don't want to install it in your mac system as the poster above said so take note of where you installed Mint and if you aren't given the right option, don't install!

The fix discovered by a poster in the other forum is to sync your partitions with rEFIT after using gparted to format your partition but before you install Mint (or whatever distro.) The steps in the order I followed are:

1) install rEFIT and boot a couple times to get it working
2) create partition with apple disk utility -- including a 2gb swap
3) boot with live dvd and use mint partition utility to format--do not install yet
4) shutdown. boot into rEFIT options (arrow key) and allow rEFIT to sync partitions when prompted (type y)
5) now reboot with live dvd and run installation

You should now have the option to install bootloader in your mint partitition (sda3 or what have you.) I hope this is helpful.

Level 1
Level 1
Posts: 12
Joined: Fri Nov 16, 2012 3:44 pm


Post by cj123 »

In the Mactel PPA should we use the deb files for Maverick, Lucid...? Is one or another more compatible with lmde?Also why not do what is suggested here?

Also (edit) after surfing the forums about the heat issue I have some more questions about the cooling system in the mac: [No need to read below unless you get a kick out of discussing the cooling configuration. I am quite happy to install the recommended tweaks once I know which one to install. I am just curious to learn more.]

First I had to configure lm sensers to get temperature readings. I am a noob but I think this is something mac users will want to have up and running. I found the directions in some forum or another it amounted to DLing lm sensors and configuring them with command: "sensors-detect." Command: "sensors" gives the read out.

Without the sensors I can confirm that my macbook runs a little warmer than in osx but the fans do come on and cool the computer without any fiddling. The other day I was streaming a flash video with wireless and my core reached 85C (which seems, without really knowing anything about it, pretty hot.) The fans were running at 6188 rpm though and the it cooled to below 60C in a minute or two after the vid ended. Is the problem that the fans need to be set to come on faster and sooner? Is that what mac fan control does? The fans were certainly working hard and doing their job.

I am curious what is mac specific about this? I ran across this wiki about which gives directions for tweaking the fan settings: ... _fan_speed
Is mac fan control any different than what is advised here for regular, non-mac computers?

Next to the cpu temp in the sensors readout it says "high = +100.0°C, crit = +100.0°C." I understand that 100C is the temperature that will kill the processor and the computer should shut down if that temp is ever reached. Seems odd that the temperature defined as high is the same as critical. I would think I was running high at 80 or so. Is this something that makes a difference and should be edited as well?

I've seen all sorts of other issues pertaining to linux and heat -- some mention cpu frequencies, others blame certain kernel versions -- it's all new to me. One suggested you shouldn't run 32 bit on a core 2 duo, which is what I'm doing now (I don't know why.) I suspect a problem might be the wireless card and I wonder if anyone has tried using a usb wifi adapter to see if that has an effect? I cleaned out the dust from my laptop and after 5 years of accumulation in a house with a dog and in an office filled with decomposing old books, it was substantial. I probably should apply some thermal goop as well. Other than this basic maintenance it is difficult to understand what is preference (e.g. "I don't want my laptop to be warm on my lap" or "the fans are obnoxiously loud and I can't hear my entertainment program") or performance based (e.g. ruin your computer by letting it overheat, waste batteries by running the fans faster than is necessary.)

With that said, I am very impressed with the performance of Mint on the old macbook, which I've moved towards to rescue it from Apple's planned obsolescence. The heating issue looks like the one stumbling block. If the tweaking goes well I might even put some money into it and invest in a solid state drive. I haven't yet fiddled with the isight but won't write an essay about it.


Level 1
Level 1
Posts: 1
Joined: Thu Oct 01, 2015 9:16 pm


Post by nickw »

:mrgreen: I registered specifically to thank @terroreek for this comment, which was 100% what I needed and saved me headaches at 3am:
When I installed LMDE on my macbook I had to install grub to /dev/sda and not /dev/sda3 to get grub working, as far I know that's not right but it worked, without overwriting refit.
My situation is not LMDE but just an ordinary install of Cinnamon 17.2 under rEFIt - one is asked where to install the bootloader and at first glance it seems unwise to install it to /dev/sda (one assumes it will wreak havoc on rEFIt etc.) but in fact, installing it to the same partition as the Mint installation will simply fail ("missing operating system" or the like). Whereas putting it on /dev/sda apparently does no damage and works right off the bat!

Even though terroreek and I have had the same experience, I would still advise caution (clonezilla?) before doing this.


Return to “LMDE Archive”