<solved>LMDE 201204 / Sid upgrade / Can't install pinta

Archived topics about LMDE 1
Forum rules
ugh
Level 1
Level 1
Posts: 30
Joined: Wed Sep 22, 2010 4:20 pm

<solved>LMDE 201204 / Sid upgrade / Can't install pinta

Postby ugh » Tue May 01, 2012 6:16 pm

Code: Select all

apt-get install pinta
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pinta : Depends: libgtk2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
         Depends: libmono-addins-gui0.2-cil (>= 0.6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

apt-get install libgtk2.0-cil libmono-addins-gui0.2-cil
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-cil : Depends: libcairo2 (>= 1.12.0) but 1.10.2-2ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

Aha!

Code: Select all

apt-cache policy libcairo2
libcairo2:
  Installed: 1.10.2-2ubuntu2
  Candidate: 1.10.2-2ubuntu2
  Version table:
     1.12.2-1 0
        500 http://mirrors.xmission.com/debian/ unstable/main amd64 Packages
     1.10.2-7 0
        500 http://debian.linuxmint.com/latest/ testing/main amd64 Packages
 *** 1.10.2-2ubuntu2 0
        700 http://packages.linuxmint.com/ debian/upstream amd64 Packages
        100 /var/lib/dpkg/status


Resolution

Code: Select all

apt-get install libcairo2/unstable
apt-get install pinta
OS: Linux Mint / Debian Sid
Kernel: 3.2.0-2-amd64
Desktop: Cinnamon

zerozero
Level 16
Level 16
Posts: 6516
Joined: Tue Jul 07, 2009 2:29 pm

Re: <solved>LMDE 201204 / Sid upgrade / Can't install pinta

Postby zerozero » Tue May 01, 2012 6:35 pm

easier fix (and you solve all the future issues like this)

Code: Select all

gksu gedit /etc/apt/preferences
and level all to 500.
what you saw here is apt-pining working, one pkg (libcairo2) set with higher priority (700) and being installed even if you have a newer v. from another repo (but set with lower pin-priority-500)
since you are using sid, i think that getting rid of this is only going to help you.
Image

[ bliss of ignorance ]


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 8 guests