[SOLVED] UP5 breaks CUPS printer

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 6
Joined: Mon Feb 16, 2009 10:18 am
Location: Biarritz, France

[SOLVED] UP5 breaks CUPS printer

Postby agrandir » Wed Sep 19, 2012 11:23 am

Having just updated to the latest version of Mint-Update and gone through a complete update using UP5 I find that my USB printer now fails to print any documents, including the Test page in spite of being listed correctly in the Printer Properties page. Using a web browser to connect to the CUPS administration tool I can see that it too lists my printer correctly but when it lists the "jobs" in wait, I see the message explaining why the job has stopped as:
Can't copy stdin to temporary file

I also have a problem with Dropbox on startup as it lists a similar problem saying that it doesn't have the correct permissions to launch the daemon. Would it be the same reason?

Because of this problem I'm putting off updating my laptop as it at least can still send jobs to the printer. Anyone else have the same problem?

Discovered by looking around at CUPS server error messages that this could be due to lack of space on the /var directory, which with me is just part of the root partition. Sure enough mine was filled by over 3 mb of cached packages by apt, so after cleaning out the cache using synaptic my Dropbox daemon starting working again. My printer still didn't work until I realised that the Xfce print manager was not pointing to CUPS (perhaps a problem when I updated with UP5 ?). In any case, this was solved simply by using the Settings tool - Printing System Selection, so now my printer is working again.

Suppose it was partly my own fault in that I should have made a bigger separate /var partition. :oops:
Before the next big upgrade I think I'll do some resizing of partitions!

Agrandir using Linux 3.2.0-3-amd64 with LMDE-Xfce

Level 1
Level 1
Posts: 43
Joined: Mon Nov 07, 2011 5:14 pm

Re: UP5 breaks CUPS printer

Postby iainrs » Fri Sep 21, 2012 10:35 am

I also have the same problem with my Samsung Clp620ND
(network printer fails after update)

if I go into system-printing and look at the properties for the printer
in the 'ink/toner levels' tab(!) Status messages I have
errors :
Printer 'clp620-mono':'cups-ipp-conformance-report'
Printer 'clp620-mono':'cups-ipp-missing-job-history'

on speaking to Samsung they admit there is a problem but no date for a solution !

A networked HP Officejet works OK

If I can't use my main printer - back to previous version of LMDE


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 62 guests