Autologin not working after update

Archived topics about LMDE 1
Forum rules
hallergard
Level 2
Level 2
Posts: 53
Joined: Wed Aug 01, 2012 4:11 am

Autologin not working after update

Postby hallergard » Wed Sep 19, 2012 5:00 pm

Had a huge update last night. Now I get asked to "Enter passwork for the keyring 'default' to unlock"

There is no change in mdm.conf or in the .gnome2/keyrings/ files. Help would be very much appreciated.

maxic
Level 1
Level 1
Posts: 13
Joined: Fri Feb 24, 2012 10:57 am

Re: Autologin not working after update

Postby maxic » Wed Sep 19, 2012 5:02 pm

Look at /etc/gdm3 or /etc/mdm conf files.

hallergard
Level 2
Level 2
Posts: 53
Joined: Wed Aug 01, 2012 4:11 am

Re: Autologin not working after update

Postby hallergard » Wed Sep 19, 2012 5:44 pm

Thanks, but /etc/mdm/mdm.conf has not changed as I mentioned and I do not have any /etc/gdm.conf file

hallergard
Level 2
Level 2
Posts: 53
Joined: Wed Aug 01, 2012 4:11 am

Autologin not working after update

Postby hallergard » Thu Sep 20, 2012 2:51 am

Had a huge update on Tuesday, after which at login I get the message: "Enter password for keyring 'default' to unlock". Actually I get it twice.

Have checked that /etc/mdm/mdm.conf has not been changed, neither the files in .gnome2/keyrings/ Also I do not have any /etc/gdm3 or gdm3.conf file.

Actually the autologin as such might be working, as I can see the desktop behind the message, which seems to be caused by my having two small scripts in autostart, both containing lines starting with 'sudo'

hallergard
Level 2
Level 2
Posts: 53
Joined: Wed Aug 01, 2012 4:11 am

Re: Autologin not working after update

Postby hallergard » Thu Sep 20, 2012 2:55 am

Correction: I do not have any /etc/gdm3.conf file

I believe I have posted this in the wrong subforum. Have reposted in Update/Upgrade Issues. Sorry!

hallergard
Level 2
Level 2
Posts: 53
Joined: Wed Aug 01, 2012 4:11 am

[SOLVED] Re: Autologin not working after update

Postby hallergard » Thu Sep 20, 2012 5:18 am

Unticking the two sudo scripts did not stop me from getting the message to "enter the password for keyring 'default' to unlock".

So went back to my backup copy before updating and updated the 1407 packages + 148 new - 34 removed, and paid close attention to the 9 question abt keep/replace. Rebooted and got the same message relating to one of my sudo scripts, and entered my password. Then the second message which was relating to the default keyring. Now I did not enter the password, just clicked OK and got a question abt using an unsafe password, which I okayed. Rebooted, and no message!

User avatar
Oscar799
Level 19
Level 19
Posts: 9414
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Autologin not working after update

Postby Oscar799 » Thu Sep 20, 2012 6:51 am

Please don't cross-post
Threads merged
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests