mintConstructor pitfalls with LMDE

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 3
Joined: Thu May 16, 2013 9:42 am

mintConstructor pitfalls with LMDE

Postby attackroomba » Sat Oct 12, 2013 6:56 pm

I can't image that mintConstructor is going to always work, so the fact that it doesn't work out of the box doesn't come as a surprise. However, unfortunately there is absolutely no error handling, so if something does go wrong, the terminal output must be reviewed to detect if anything broken during the steps.

I'm compiling a list of the issues I encountered with it so far in my usage to re-spin LMDE with the latest update pack. I followed these instructions ( to re-spin the ISO, and these instructions (viewtopic.php?f=198&t=146220&p=769834#p768772) to perform the update inside the chroot.

The first issue I encountered was because included in the latest update is a move to a newer kernel, 3.10-2. In order to perform the initramfs update, I mounted the following file systems outside of mintConstructor:

Code: Select all

mount -o bind /proc /path/to/working_dir/root/proc
mount -o bind /dev /path/to/working_dir/root/dev
mount -o bind /sys /path/to/working_dir/root/sys

Make sure to unmount them after the chroot step is complete, otherwise errors will appear when attempting to squashfs the system.

Code: Select all

umount /path/to/working_dir/root/proc
umount /path/to/working_dir/root/sys
umount /path/to/working_dir/root/dev

The second issue I encountered has to do with the initrd (initramfs) image, and the fact that it's assembled differently from previous kernels for whatever reason when a package called intel-microcode is installed. The expectation of mintConstructor is that the initrd will be gzip'd, or lmza'd, with the 3.10 kernel in testing, it appears to have a CPIO package prepended to it which contains some intel microcodes. This results in the following error when mintConstructor gets to updating it:

Code: Select all

lzma: Decoder error

Subsequent errors appear as a result, but the script continues assuming everything is OK. It's important to run mintConstructor from a terminal so that this output can be seen and reviewed during execution.

To return the initramfs image to the tradition format, I removed the intel-microcode package using apt-get:

Code: Select all

apt-get purge intel-microcode

The third issue I encountered was after, the squashfs system was made, the first time I ran it, no ISO was created. This was due to an error that occurred during the iso creation step where it says that he Volume sting is too long.

I was using the string "LinuxMint Debian Edition 64-bit", just for a quick fix, I went with a much shorter string which seemed to work, "lmde-20131012". Word on the street is that the volume ID is limited to 32 characters, however, the string I chose above is 31 in length.

Unfortunately, the ISO doesn't load into the MATE DE completely in my VMware Player, but I tested the ISO on a bare metal system and it worked fine. The ISO does complete building, and successfully boots loading the kernel, and initrd.

Level 9
Level 9
Posts: 2998
Joined: Fri Aug 19, 2011 3:46 am

Re: mintConstructor pitfalls with LMDE

Postby Monsta » Mon Oct 14, 2013 5:46 am

Thanks a lot for mentioning these quirks :)
I've reported them on github.

Return to “Archive”