Mate doesn't fully start

Archived topics about LMDE 1
Forum rules
the_loaf
Level 1
Level 1
Posts: 26
Joined: Tue Nov 12, 2013 2:39 pm

Mate doesn't fully start

Postby the_loaf » Tue Feb 04, 2014 4:15 pm

Howdy!

After some updates this morning, and a subsequent reboot, my system wont fully go into Mate desktop.

I see a mouse pointer and a terminal in the upper left hand corner. I can start mate apps and chromium from the command line
and they will appear, but the windows are unmovable and can't be resized or minimized. However, no start menu, no panels, etc.

When I exit, and login as a different user (I created a new user to see if I messed something up in my home directory), the same thing
happens. So it's not a config file in my home directory.

I don't have any .xsession errors that I can see.

I am running LMDE Mate 64bit edition on a T410. Everything was fine until the update this morning (around 8am PST).

I can ctrl+alt-F1 to get to a tty.

I am currently copying my data off the disk drive and will probably do a reinstall if I can't get this going, but what a pain!

Any pointers?

cowdemon
Level 1
Level 1
Posts: 2
Joined: Tue Feb 04, 2014 11:53 am

Re: Mate doesn't fully start

Postby cowdemon » Tue Feb 04, 2014 5:51 pm

My Mate was completely uninstalled and I was forced into the Gnome fallback. From then, it only got worse, as the OS informed me I had additional items to upgrade (about 1800 of them), which resulted in my keyboard and touchpad not working at all. I can't log into my computer.

It seems I will have to reinstall as well. :-(

the_loaf
Level 1
Level 1
Posts: 26
Joined: Tue Nov 12, 2013 2:39 pm

Re: Mate doesn't fully start

Postby the_loaf » Tue Feb 04, 2014 6:34 pm

Oh well, it was my work machine and I really had to get it up and running. I copied off the data. I reinstalled. It's updating now. Will copy back my home directory in a bit.
some weird messages updating. I hope it works . . .

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: Mate doesn't fully start

Postby Monsta » Wed Feb 05, 2014 3:34 am

cowdemon wrote:My Mate was completely uninstalled

Did the Update Manager really offer you to do that?

Run this command. What does it say?

Code: Select all

aptitude search ~imate

Cucumber
Level 1
Level 1
Posts: 2
Joined: Thu Feb 06, 2014 3:45 am

Re: Mate doesn't fully start

Postby Cucumber » Thu Feb 06, 2014 3:56 am

the_loaf wrote:I see a mouse pointer and a terminal in the upper left hand corner.

Code: Select all

sudo apt-get install mint-meta-debian-mate

Ctrl+D and in login window select "Mate"
Last edited by Cucumber on Thu Feb 06, 2014 5:16 am, edited 2 times in total.

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: Mate doesn't fully start

Postby Monsta » Thu Feb 06, 2014 3:58 am

Code: Select all

mint-meta-debian-mate

Cucumber
Level 1
Level 1
Posts: 2
Joined: Thu Feb 06, 2014 3:45 am

Re: Mate doesn't fully start

Postby Cucumber » Thu Feb 06, 2014 5:14 am

All right. Thank's. Сorrected

queson
Level 1
Level 1
Posts: 8
Joined: Mon Jun 13, 2011 5:17 am

Re: Mate doesn't fully start

Postby queson » Thu Feb 06, 2014 6:39 am

Howdy

When rebooting after UP8-update the log-in screen don't offer any options,
and I end up in GNOME-session .

MATE -installition ok but won't show up at log-in. How to start MATE from tty or terminal ??

I miss my MATE

Code: Select all

antlmd@antlmd-dt:~$ dpkg -s mate-window-manager
Package: mate-window-manager
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 46
Maintainer: Stefano Karapetsas <stefano@karapetsas.com>
Architecture: all
Version: 1.6.1-1
Depends: marco (>= 1.6.1-1)
Description: MATE lightweight GTK+ window manager (metapackage)
 This is a metapackage depending on the default MATE window manager.
 .
 Marco is a small window manager, using GTK+ to do everything. It is
 developed mainly for the MATE Desktop.
Homepage: http://www.mate-desktop.org/
antlmd@antlmd-dt:~$

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: Mate doesn't fully start

Postby Monsta » Thu Feb 06, 2014 8:31 am

queson wrote:When rebooting after UP8-update the log-in screen don't offer any options,
and I end up in GNOME-session .

If there's some problem with the login screen I think it's worth doing what Clem suggested here.

Also try installing mint-meta-debian-mate as suggested above.

dbz
Level 1
Level 1
Posts: 15
Joined: Sat Aug 20, 2011 10:46 am

Re: Mate doesn't fully start

Postby dbz » Thu Feb 06, 2014 1:51 pm

Also please take a look at my thread: viewtopic.php?f=198&t=158536

I had similar problem. You may check /var/log/syslog for errors about libfreetype library and not upgrade it at all if there are any errors in the log. Also setting up a greeter helps to give an obvious look to a login screen (though it's just a workaround as I understood).

queson
Level 1
Level 1
Posts: 8
Joined: Mon Jun 13, 2011 5:17 am

Re: Mate doesn't fully start

Postby queson » Fri Feb 07, 2014 6:33 am

Thank's for tip but I don't find any libfreetype error.

I don't think it is a login problem but missing mate-packets, e.g. mate-core is removed.
But when trying to install these packets I meet with problems.
How to first totally remove MATE and then reinstall MATE ?
GNOME will do but I miss my MATE

Code: Select all

antlmd@antlmd-dt:~$ inxi -SGx
System:    Host: antlmd-dt Kernel: 3.11-2-686-pae i686 (32 bit, gcc: 4.8.1) Desktop: Gnome Distro: Linux Mint Debian Edition
Graphics:  Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           X.Org: 1.14.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1360x768@59.8hz
           GLX Renderer: Mesa DRI Intel Ivybridge Desktop x86/MMX/SSE2 GLX Version: 3.0 Mesa 9.2.2 Direct Rendering: Yes
antlmd@antlmd-dt:~$


Code: Select all

antlmd@antlmd-dt:~$ sudo aptitude  install mate-core
[sudo] password for antlmd:
Följande NYA paket kommer att bli installerade:
  libmatedesktop{a} libmatekbd{a} libmatekeyring{a} libmatewnck{ab}
  mate-core
0 paket att uppgradera, 5 att nyinstallera. 0 att ta bort och 0 inte uppgraderade.
Behöver hämta 399 kB/484 kB arkiv. Efter uppackning kommer 2 619 kB diskplats att användas.
Följande paket har otillfredsställda beroenden:
 libmatekbd4 : Står i konflikt med: libmatekbd men 1.6.0-1 kommer att installeras.
               Gör sönder: libmatekbd men 1.6.0-1 kommer att installeras.
 libmatewnck : Beroende av: libmatewnck-common (= 1.6.0-1) men 1.6.1-1+lmde är installerat.
 libmate-keyring1 : Står i konflikt med: libmatekeyring men 1.6.0-1 kommer att installeras.
 libmate-desktop-2-17 : Står i konflikt med: libmatedesktop men 1.6.0-3+8.jessie kommer att installeras.
 libmatewnck0 : Står i konflikt med: libmatewnck men 1.6.0-1 kommer att installeras.
                Gör sönder: libmatewnck men 1.6.0-1 kommer att installeras.
Följande åtgärder kommer att lösa dessa beroenden:

     Ta bort följande paket:                           
1)     atril                                           
2)     libatril                                         
3)     libmate-keyring1                                 
4)     mate-power-manager                               

     Behåll följande paket vid deras nuvarande version:
5)     libmatedesktop [Inte installerat]               
6)     libmatekbd [Inte installerat]                   
7)     libmatewnck [Inte installerat]                   
8)     mate-core [Inte installerat]                     

     Leave the following dependencies unresolved:       
9)     mate-screensaver rekommenderar mate-power-manager


Acceptera denna lösning? [Y/n/q/?]

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: Mate doesn't fully start

Postby Monsta » Fri Feb 07, 2014 7:21 am

I'll have to repeat:

Code: Select all

sudo apt-get install mint-meta-debian-mate

queson
Level 1
Level 1
Posts: 8
Joined: Mon Jun 13, 2011 5:17 am

Re: Mate doesn't fully start

Postby queson » Fri Feb 07, 2014 8:30 am

Thanks Monsta, but already done

Code: Select all

antlmd@antlmd-dt:~$ sudo apt-get install mint-meta-debian-mate
[sudo] password for antlmd:
Läser paketlistor... Färdig
Bygger beroendeträd         
Läser tillståndsinformation... Färdig
mint-meta-debian-mate is already the newest version.
0 att uppgradera, 0 att nyinstallera, 0 att ta bort och 0 att inte uppgradera.
antlmd@antlmd-dt:~$















and now again

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: Mate doesn't fully start

Postby Monsta » Fri Feb 07, 2014 8:40 am

Then you already have all the needed MATE packages installed. So leave it alone and try the workarounds for MDM:

clem wrote:First, check to see if nicknames appear on the login screen. If so, click on them or press the UP or DOWN arrows of the keyboard to select a user. If no names appear, then it could be an issue with webkit, and in this case the solution is to use the GTK greeter. To do so, switch to console with CTRL-ALT-F1, and edit /etc/mdm/mdm.conf. In the [daemon] section, specify “Greeter=/usr/lib/mdm/mdmlogin”. Save the file, kill and restart MDM, or reboot the computer. You should then be greeted with a GTK login screen.
clem wrote:- A critical bug was discovered in MDM 1.4.10 which prevents some users from logging in (people with "DefaultFace=" in their /etc/mdm/mdm.conf). The login screen appears but without any usernames.
- The cause of the bug was understood.
- A fix was implemented.
- MDM 1.4.11 will hit LMDE tomorrow to fix this issue.
- In the meantime, the easier workaround is to switch to console with CTRL+ALT+F1, type "startx" to launch Xorg, launch mdmsetup or "Login Window" and select a "GDM" theme. Upon the next reboot the login screen should be fully functional.

queson
Level 1
Level 1
Posts: 8
Joined: Mon Jun 13, 2011 5:17 am

Re: Mate doesn't fully start

Postby queson » Fri Feb 07, 2014 8:52 am

Better up, I just got MDM 1.4.11. , and all works fine and dandy

Thanks again Monsta


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 2 guests