[SOLVED] Cinnamon Settings Broken after UP8

Archived topics about LMDE 1
Forum rules
eblmde
Level 1
Level 1
Posts: 4
Joined: Sun Mar 16, 2014 4:51 pm

[SOLVED] Cinnamon Settings Broken after UP8

Postby eblmde » Sun Mar 16, 2014 5:12 pm

I'm having trouble changing any Cinnamon settings after upgrading to UP8. I can change them on the System Settings panel, but when I close the panel and open it again, the default settings are back. This happens with Themes, Screensaver & Lock Settings, Power Management, and others.

The backstory:

I'm pretty new to Linux. Started with LMDE at UP6. I'm not sure if it's related, but I had problems when I upgraded to UP7. For that UP, I "lost" Cinnamon and used XFCE. When I upgraded to UP8, I followed all the instructions on Update Pack Info. I've confirmed that I can still change related settings when I log in using XFCE as my DE.

FWIW, I'll include the output from "inxi -Fxz" below. Thanks for your help.

System: Host: debmac Kernel: 3.11-2-amd64 x86_64 (64 bit, gcc: 4.8.1)
Desktop: Cinnamon 2.0.14 (Gtk 2.24.22) Distro: LinuxMint 1 debian
Machine: System: Apple product: Macmini5 2 version: 1.0
Mobo: Apple model: Mac-4BC72D62AD45599E version: Macmini5 2
Bios: Apple version: MM51.88Z.0077.B10.1201241549 date: 01/24/2012
CPU: Dual core Intel Core i5-2520M CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9977.3
Clock Speeds: 1: 1350.00 MHz 2: 1000.00 MHz 3: 800.00 MHz 4: 1200.00 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] bus-ID: 01:00.0
X.Org: 1.14.3 driver: fglrx Resolution: 1024x768@60.0hz
GLX Renderer: AMD Radeon 6600M and 6700M Series GLX Version: 4.3.12438 - CPC 13.20.5 Direct Rendering: Yes
Audio: Card-1: Advanced Micro Devices [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
driver: snd_hda_intel bus-ID: 01:00.1
Card-2: Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Card-3: Asahi Kasei Microsystems AK5370 I/F A/D Converter driver: USB Audio usb-ID: 001-008
Sound: Advanced Linux Sound Architecture ver: k3.11-2-amd64
Network: Card-1: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge bus-ID: 03:00.0
IF: wlan0 state: up mac: <filter>
Card-2: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3 ver: 3.132 bus-ID: 02:00.0
IF: eth1 state: down mac: <filter>
Drives: HDD Total Size: 500.1GB (6.8% used) 1: id: /dev/sda model: APPLE_HDD_HTS547 size: 500.1GB
Partition: ID: / size: 243G used: 32G (14%) fs: ext4 ID: swap-1 size: 2.71GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 71.0C mobo: N/A gpu: 4294967.50C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 163 Uptime: 39 min Memory: 811.1/3940.4MB Runlevel: 2 Gcc sys: 4.8.2
Client: Shell (bash 4.2.45) inxi: 1.9.14
Last edited by eblmde on Tue Aug 12, 2014 11:46 pm, edited 1 time in total.

Monsta
Level 9
Level 9
Posts: 2924
Joined: Fri Aug 19, 2011 3:46 am

Re: Cinnamon Settings Broken after UP8

Postby Monsta » Mon Mar 17, 2014 3:34 am

eblmde wrote:I'm having trouble changing any Cinnamon settings after upgrading to UP8. I can change them on the System Settings panel, but when I close the panel and open it again, the default settings are back. This happens with Themes, Screensaver & Lock Settings, Power Management, and others.

This is a problem with cinnamon-settings-daemon and it should have been fixed some time ago. Check whether your system is fully updated. And just in case, make sure all Cinnamon-related packages are installed:

Code: Select all

apt install mint-meta-debian-cinnamon

eblmde
Level 1
Level 1
Posts: 4
Joined: Sun Mar 16, 2014 4:51 pm

Re: Cinnamon Settings Broken after UP8

Postby eblmde » Mon Mar 17, 2014 11:58 pm

Thanks for the suggestions.

I tried them all with no luck so far. :( Updating mint-meta-debian-cinnamon got me 3 new packages and had me remove 1, though.

When I check Update Manager or Synaptic, I don't see any indication that there are updates I haven't performed.

I also read through the thread you linked to. The Region & Language trick didn't apply to me, and I had even less success booting into my previous kernel (3.10-2) -- it went direct to the console prompt, and startx errored.

User avatar
killer de bug
Level 12
Level 12
Posts: 4334
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Cinnamon Settings Broken after UP8

Postby killer de bug » Tue Mar 18, 2014 9:36 am

It should not be related but did you remove gnome-control-center and gnome-control-center-data?
Can you also run

Code: Select all

apt dist-upgrade
and make sure it doesn't offer to upgrade any package?
Image
If it ain't broke, fix it until it is.

eblmde
Level 1
Level 1
Posts: 4
Joined: Sun Mar 16, 2014 4:51 pm

Re: Cinnamon Settings Broken after UP8

Postby eblmde » Tue Mar 25, 2014 12:33 am

Thanks for that.

I removed gnome-control-center-data, but gnome-control-center was not installed. Then I ran apt dist-upgrade (after apt update), but got no upgrades or new installs.

Still can't change Cinnamon settings, though.

abtygwyn
Level 3
Level 3
Posts: 195
Joined: Mon Apr 25, 2011 4:33 am

Re: Cinnamon Settings Broken after UP8

Postby abtygwyn » Thu May 29, 2014 3:11 am

This is probably a long way round but I've just bought a new laptop and tried loading UP6 and then updating. It didn't like it. So I went back to square one, downloaded the latest image and hey, it works out of the box. Just don't go to 'testing' though or cinnamon will definitely go pear shaped again at present.

I'm a complete novice at this ... but it worked for me! :-)

eblmde
Level 1
Level 1
Posts: 4
Joined: Sun Mar 16, 2014 4:51 pm

Re: Cinnamon Settings Broken after UP8

Postby eblmde » Tue Aug 12, 2014 11:46 pm

About a month ago I re-installed from the latest image, and everything has worked fine since.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests