Update manager screwed, can't update to UP8

Archived topics about LMDE 1
Forum rules
DougB
Level 2
Level 2
Posts: 79
Joined: Thu Oct 27, 2011 8:14 am

Update manager screwed, can't update to UP8

Postby DougB » Fri Mar 21, 2014 11:20 am

I've been trying to update a laptop to UP8 from UP7 (Cinnamon).
Update manager says 'fix broken packages first', but Synaptic manager shows no broken packages
.
I've gone through the steps in the Update Pack Info, except that the command 'mintsources' produced an error message that there was no such command.
I installed 'mintsources' through Synaptic, but trying to run it produced an error message again.

This left me with no sources in /etc/apt/sources.list.d, so I copied the two official.... repositories from a working UP8 installation into /etc/apt/sources.list.d

I've tried 'apt-get update' after commenting out the entries in the two official.... repositories and again after removing the comments...... Update manager stays the same.

I attempted to use the Fix MergeLIst Problems but Adminstration=>Software Sources accepts my administrator password and then disappears.

My current state is that Synaptic Manager looks normal and shows no broken packages
Update Manager shows a long list of packages to be installed but will not proceed until the "broken" packages are fixed.

What should I do?

kurotsugi
Level 6
Level 6
Posts: 1055
Joined: Fri Jan 25, 2013 3:54 am

Re: Update manager screwed, can't update to UP8

Postby kurotsugi » Fri Mar 21, 2014 11:36 am

can you show us the result of 'inxi -r'?

Monsta
Level 9
Level 9
Posts: 2925
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager screwed, can't update to UP8

Postby Monsta » Fri Mar 21, 2014 12:19 pm

DougB wrote:I've gone through the steps in the Update Pack Info, except that the command 'mintsources' produced an error message that there was no such command.

That means you didn't read the notes carefully.

Code: Select all

apt install mint-meta-debian-cinnamon

But of course, first you have to fix the broken packages:

Code: Select all

apt install -f

DougB
Level 2
Level 2
Posts: 79
Joined: Thu Oct 27, 2011 8:14 am

Re: Update manager screwed, can't update to UP8

Postby DougB » Fri Mar 21, 2014 5:37 pm

kurotsugi:

here is the output of inxi -r
Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com debian main upstream import
deb http://lmde-mirror.gwendallebihan.net/latest/ testing main contrib non-free
deb http://lmde-mirror.gwendallebihan.net/latest/security testing/updates main contrib non-free
deb http://lmde-mirror.gwendallebihan.net/latest/multimedia testing main non-free
deb http://extra.linuxmint.com debian main
Active apt sources in file: /etc/apt/sources.list.d/official-source-repositories.list
deb-src http://packages.linuxmint.com debian main upstream import
deb-src http://lmde-mirror.gwendallebihan.net/latest/ testing main contrib non-free
deb-src http://lmde-mirror.gwendallebihan.net/latest/security testing/updates main contrib non-free
deb-src http://lmde-mirror.gwendallebihan.net/latest/multimedia testing main non-free
deb-src http://extra.linuxmint.com debian main
.................................................................
Monsta:
<quote>
That means you didn't read the notes carefully.

Code: Select all
apt install mint-meta-debian-cinnamon


But of course, first you have to fix the broken packages:

Code: Select all
apt install -f
<endquote>

Actually I did read the notes carefully and ran
apt install mint-meta-debian-cinnamon.

Admittedly I did not run
apt install -f
on the other hand I had run
apt-get autoremove
when prompted (during apt-get update if I remember rightly).

However I've now run

apt install -f
apt-get autoremove
apt install mint-meta-debian-cimmamon
apt-get update
[mv /etc/apt/sources.list /etc/apt/sources.list.bk gets the message that the file doesn't exist]
apt remove --purge software-properties-gtk mint-debian-mirrors [gets the message that neither is installed so isn't removed].

Synaptic manager is the same and reports no broken packages
Update manager still gives a long list of packages to add and update but then stops with "Fix broken packages first".

Where are these broken packages if Synaptic doesn't find them?
How do I unbork the system?

kurotsugi
Level 6
Level 6
Posts: 1055
Joined: Fri Jan 25, 2013 3:54 am

Re: Update manager screwed, can't update to UP8

Postby kurotsugi » Sat Mar 22, 2014 1:47 am

you have double repo list. you can delete one of them. after that please give us the result of

Code: Select all

sudo apt-get update
aptitude -s dist-upgrade

Monsta
Level 9
Level 9
Posts: 2925
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager screwed, can't update to UP8

Postby Monsta » Sat Mar 22, 2014 3:38 am

kurotsugi wrote:you have double repo list.

No he doesn't. Have you heard of source package repositories?

Monsta
Level 9
Level 9
Posts: 2925
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager screwed, can't update to UP8

Postby Monsta » Sat Mar 22, 2014 3:42 am

DougB wrote:Synaptic manager is the same and reports no broken packages
Update manager still gives a long list of packages to add and update but then stops with "Fix broken packages first".

Probably some bug in the Update Manager. That's not a problem, you can upgrade via the terminal:

Code: Select all

apt update && apt dist-upgrade

Note: please use the "code" tag when posting the terminal output.
Note 2: <quote> and <endquote> are not valid tags for this forum.

DougB
Level 2
Level 2
Posts: 79
Joined: Thu Oct 27, 2011 8:14 am

Re: Update manager screwed, can't update to UP8

Postby DougB » Sat Mar 22, 2014 8:34 am

Monsta, thanks for the advice.
I ran

Code: Select all

apt-get update && apt dist-upgrade


this downloaded a large number of packages and seemed to install many but reported some missing, so (as prompted) I also ran

Code: Select all

apt-get update --fix-missing

as well.
Update manager was unaffected.
I saw that the kernel had not been updated so installed kernel-3.11 via synaptic, updated grub and re-booted.
The desktop appearance has not been updated to UP8.
Synaptic reports no broken packages.
Update manager still reports 1515 packages to be updated and then
Fix broken packages first

Monsta
Level 9
Level 9
Posts: 2925
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager screwed, can't update to UP8

Postby Monsta » Sat Mar 22, 2014 9:54 am

DougB wrote:The desktop appearance has not been updated to UP8.

What, UP8 should have some distinct desktop appearance? :D

DougB wrote:Update manager still reports 1515 packages to be updated

Well, just refresh it.

Run dist-upgrade once more to make sure it will tell you that no packages are waiting to be updated.

kurotsugi
Level 6
Level 6
Posts: 1055
Joined: Fri Jan 25, 2013 3:54 am

Re: Update manager screwed, can't update to UP8

Postby kurotsugi » Sat Mar 22, 2014 12:13 pm

oops...it seems that I've missed the src.

DougB
Level 2
Level 2
Posts: 79
Joined: Thu Oct 27, 2011 8:14 am

Re: Update manager screwed, can't update to UP8

Postby DougB » Mon Mar 24, 2014 8:05 am

What, UP8 should have some distinct desktop appearance?

The login screens in UP 7 and UP8 are quite different

As you advise, I repeated dist-upgrade. This time it appeared that packages were being downloaded and installed until the process stopped with the following error:
[Obsolete major version 9.1

The PostgreSQL version 9.1 is obsolete, but the server or client
packages are still installed. Please install the latest packages
(postgresql-9.3 and postgresql-client-9.3) and upgrade the existing
clusters with pg_upgradecluster (see manpage).

Please be aware that the installation of postgresql-9.3 will
automatically create a default cluster 9.3/main. If you want to upgrade
the 9.1/main cluster, you need to remove the already existing 9.3
cluster (pg_dropcluster --stop 9.3 main, see manpage for details).

The old server and client packages are no longer supported. After the
existing clusters are upgraded, the postgresql-9.1 and


The old server and client packages are no longer supported. After the
existing clusters are upgraded, the postgresql-9.1 and
postgresql-client-9.1 packages should be removed.

Please see /usr/share/doc/postgresql-common/README.Debian.gz for
details.


At this point I'm stymied.

Synaptic manager, apt-get and dpkg all halt with the error:

Code: Select all

apt-get install postgresql-9.3 postgresql-client-9.3
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
root@vpcsb:/home/dougb# apt-get install postgresql-9.3
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.


and then

Code: Select all

dpkg --configure -a

stops with the original error
Obsolete major version 9.1

The PostgreSQL version 9.1 is obsolete, but the server or client
packages are still installed. Please install the latest packages
(postgresql-9.3 and postgresql-client-9.3) and upgrade the existing
clusters with pg_upgradecluster (see manpage).
...............etc]


Where to next?

Monsta
Level 9
Level 9
Posts: 2925
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager screwed, can't update to UP8

Postby Monsta » Mon Mar 24, 2014 10:01 am

DougB wrote:The login screens in UP 7 and UP8 are quite different

:D Is that all the "new desktop appearance"? A simple change of the default MDM greeter, the thing that you only see when you log in?

DougB wrote:Obsolete major version 9.1

The PostgreSQL version 9.1 is obsolete, but the server or client
packages are still installed. Please install the latest packages
(postgresql-9.3 and postgresql-client-9.3) and upgrade the existing
clusters with pg_upgradecluster (see manpage).

This looks like an informational message, not an error one.
Anyway, do you need postgresql? If not, remove it.

DougB
Level 2
Level 2
Posts: 79
Joined: Thu Oct 27, 2011 8:14 am

[SOLVED] Re: Update manager screwed, can't update to UP8

Postby DougB » Tue Mar 25, 2014 9:43 am

Is that all the "new desktop appearance"? A simple change of the default MDM greeter, the thing that you only see when you log in?


:) Let's not get carried away! I mentioned this only as a clear sign that the update was failing

Re postgresql:
I tried to remove postgresql but was refused because of many dependencies.
So I tried to install postgresql-9.3 via apt-get and synaptic but was stymied by coming back to the same point -

Code: Select all

   dpkg --configure -a 

which then stopped with the message about postgresql.

In the end I downloaded postgresql-9.3 from the debian website into my Download folder and tried

Code: Select all

  dpkg -i postgresql-9.3_9.3.4-1_amd64.deb

from that folder.

After dealing with a lot of further dependencies postgresql-9.3 did install and

Code: Select all

apt-get dist-upgrade


then went ahead to completion.

Phew :roll:

So finally [SOLVED]
Thanks for your continued help!

Monsta
Level 9
Level 9
Posts: 2925
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager screwed, can't update to UP8

Postby Monsta » Tue Mar 25, 2014 10:08 am

Check whether the system is really fully updated. Run

Code: Select all

apt install -f

Code: Select all

apt dist-upgrade

It should tell you that there are 0 packages to update and that there are no broken dependencies.

DougB
Level 2
Level 2
Posts: 79
Joined: Thu Oct 27, 2011 8:14 am

Re: Update manager screwed, can't update to UP8

Postby DougB » Tue Mar 25, 2014 2:50 pm

Monsta, many thanks again.
I've run the code (and done some autoremove). All is fine :D


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests