SOLVED: Installing foo2zjs for Minolta 2430DL removes CUPS.

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 16
Joined: Mon Dec 27, 2010 4:18 pm

SOLVED: Installing foo2zjs for Minolta 2430DL removes CUPS.

Postby faffmeister » Sat Oct 01, 2011 7:40 pm

Fixed it!

(edit: 111215.

A couple of qualifications ...

i) You may need to uninstall the existing foomatc-db-engine first.

ii) I have found since posting that although the printer now works, the toner deposition at 2400x600dpi colour seem to be very much heavier than when I use the same printer on a MEPIS 7.0 installation using earlier versions of the affected files.

Text comes out very, very black and somewhat hazy whilst colour pictures are very dark. 600x600dpi monochrome printing seems OK. I haven't compared 1200x600dpi color yet.)

Open Synaptic > Settings > Repositories > Other Software tab


main contrib non-free

Click +Add Source

This may also bring in:

main contrib non-free

Still in the Other Software tab, make a note of and then deselect all other sources and select "Debian 6.0 'Squeeze' "

Click "Close"

Close the "Repositories changed" message.

Click the "Reload" button.

Then click anywhere in the available software list area and type "foo2zjs".

This will find the package. Mark it for installation and from the "Mark recommended for installation" drop down list select foomatic-db-engine.

Click Apply and then Apply in the popup.

That will install
foo2zjs 20090908dfsg-5.1+squeeze
foomatic-db-engine 4.0.4-3

Then go back to

Synaptic > Settings > Repositories > Other Software tab

and select the sources that you made a note of in the first place and deselect "Debian 6.0 'Squeeze' " (both entries if the Source Code has been included).

Click "Reload".

You should now be able to set up your printer from the "Administration > Printing" menu option.

Worked for me.


Original post:

So I can't print.

Installed LMDE 64bit 201101 on my Toshiba Satellite L500 and then installed foo2zjs so that I could print using a Minolta Magicolor 2430DL. Fine, no problem.

Decided to then do a clean install of LMDE 64bit 201109 and then Update pack 3. All seemed to go fine till installed foo2zjs.

Went through this using Synaptic.

Trouble is, I've done it so many times on other machines that I didn't notice that cups and cups-driver-gutenprint were to be removed whilst foomatic-db-engine were to be installed.

Clicked apply and then found that the print system was no longer connected to the CUPS server .... because it had been removed of course.

Reinstalled cups but that then removes foo2zjs and foomatic-db-engine. So back where I started with no printer.

I have installed foo2zjs on another machine Lenovo Thinkpad Edge15) running LMDE 64bit 201109 with Update pack 2 and that works fine. So I think it's something to do with the foomatic-db-engine 4.0.8 dependency problem referred somewhere else in this forum.

Does anyone know of a way to work round this (or know if a fix is in the pipeline)?
Last edited by faffmeister on Thu Dec 15, 2011 9:33 am, edited 2 times in total.

User avatar
Level 4
Level 4
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Installing foo2zjs for Minolta 2430DL printer removes CU

Postby twa » Mon Oct 03, 2011 5:15 am

see this:
but I do not know how to solve yr problem.
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests