Unable to start 'gnome-settings-daemon' after Update 3

Archived topics about LMDE 1
Forum rules
Level 1
Level 1
Posts: 15
Joined: Thu Oct 27, 2011 3:02 am

Unable to start 'gnome-settings-daemon' after Update 3

Postby 0mull » Thu Oct 27, 2011 3:36 am

Hello everybody,

First off, I am new to the community, so hi everyone. I have been using LMDE for the last 6 months or so, and am happy with it although some instabilities and glitches are annoying. I am exactly in this situation, this is why I post. I have the following problem:

After installing update pack 3 (following the guide in the blog, which worked fine) the toolbars and the whole gui aquired a grey somewhat strange and broken looking appearance. Leftovers from the originam theme still leak through at some points, like the 'menu' button or the window titlebars are still looking how they should, but other things just turned weird. When I try to open "Appeareance" from the mint-menu, I get the following error message

Unable to start the settings manager 'gnome-settings-daemon'.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with DBus, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.

The appearance gui menu then starts, but changes in the theme cause only partially changes to the system, and changes to the fonts change nothing at all.

starting the gnome-settings-daemon from the terminal (with sudo, don't know if this is appropriate) does change something, like a lot of the icons get back to how they used to look like, but other strange color or toolbar errors stay. Terminal standard out reads:

Code: Select all

** (gnome-settings-daemon:3318): WARNING **: Failed to acquire org.gnome.SettingsDaemon

** (gnome-settings-daemon:3318): WARNING **: Could not acquire name

This problem has been encountered by others too. I found this threat http://forums.linuxmint.com/viewtopic.php?f=199&t=65317&start=20, but it ran out without a solution besides some hacks that did not change the problem for me. And, the users in the thread notice this problem only once every few boots or so, while in my system it turns up regulary. I could reproduce the problem after a fresh clean new install, twice.

What else should I include? Oh yes, of course, LMDE 64bit. I would be happy if anyone could give me a hint about what is actually going on here or help me out in any way. The problem seems very confusing and although I can work on the computer, It really looks and feels ugly as hell.

Thanks, Georg

I might add, that when starting the keyboard layout manager, I get the same error. Also, the ctrl+alt+backspace sequence to kill the x-server does not work

another edit:
Also , the process "gnome-appearanc" is defunct and not killable

Level 1
Level 1
Posts: 15
Joined: Thu Oct 27, 2011 3:02 am

Re: Unable to start 'gnome-settings-daemon' after Update 3

Postby 0mull » Thu Nov 03, 2011 3:50 am

No idea anyone?

In the meantime I have discovered that this problem is user-specific. When I generate a new User account and log in there, things are perfectly fine. This leads me to the notion, that some user specific config file is messed up. Which one could it be? In a desperate attempt I tried to replace my .gconf and .gnome2 folder with the blank and newly created ones by the new user account, making some icons look different, but leaving the appearance, keyboard and mouse manager with the same error and unresponsive.

Any ideas?

User avatar
Level 4
Level 4
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Unable to start 'gnome-settings-daemon' after Update 3

Postby twa » Thu Nov 03, 2011 12:37 pm

I experience same problem.
once in a while I get the warning and all icons, themes and fonts are changed.
have to personalize again from menu>preferences>aspect.
have no idea why this happens.
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest