Screen suspending after 10 minutes of inactivity

Archived topics about LMDE 1
Forum rules
rolandpish
Level 2
Level 2
Posts: 54
Joined: Sun Jul 25, 2010 4:33 pm

Screen suspending after 10 minutes of inactivity

Postby rolandpish » Mon Sep 27, 2010 4:30 pm

Hi there.

I recently installed LMDE and installed Xfce to be my main desktop.

What happens with my computer is that after aprox. 10 minutes of inactivity, the LCD screen suspends and it "sleeps" even though I set up the energy and screensaver settings to avoid doing such thing.

I disabled the screensaver and I configured the Xfce4 energy settings to "sleep" the screen after 60 minutes of inactivity, but instead, it's sleeping after aprox. 10 minutes.
I surfed across all the configuration options and never found such an option (only in Xfce4 energy settings).

Where can I edit this configuration apart from the Xfce4 energy settings?

Thanks in advance!

maurosor
Level 1
Level 1
Posts: 1
Joined: Fri Sep 24, 2010 2:04 am
Location: California, USA.
Contact:

Re: Screen suspending after 10 minutes of inactivity

Postby maurosor » Tue Sep 28, 2010 9:23 am

Same thing here, It's starting to annoy me.

rolandpish
Level 2
Level 2
Posts: 54
Joined: Sun Jul 25, 2010 4:33 pm

Re: Screen suspending after 10 minutes of inactivity

Postby rolandpish » Tue Sep 28, 2010 9:28 am

maurosor wrote:Same thing here, It's starting to annoy me.

Hi maurosor, do you have also Xfce as your main desktop? Or are you using Gnome?

Are people using Gnome experiencing the same behaviour?

Cheers

robert-e
Level 3
Level 3
Posts: 156
Joined: Fri Nov 27, 2009 1:38 am

Re: Screen suspending after 10 minutes of inactivity

Postby robert-e » Tue Sep 28, 2010 2:50 pm

Ditto here; using 32 bit Mint 9, gnome on a desktop (this also happens on my laptop). I have seen this problem for a at least a year, in both Fedora, Mint 9, and now LMDE. It gets mentioned once in a while, but the problem remains. I have and do try all sorts of things to mitigate this, but to no avail. I am suspecting that it is a kernel problem, and in these days of kernel modules, I have little hope that it gets fixed. Heck...I imagine that the kernel guys consider it a feature and not a bug lol. I guess we will have to live with it some more. Acutally, the only time it really bugs me, is when I am expecting an email from the gmail server, and I look over at the computer to see if it has arrived, only to see the darn blank screen. I have then to walk over and move the mouse to see the screen; every ten minutes. It gets old real fast...and I get pi$$ed all over again.

Oh well. Life in the Linux lane....

Bob

rolandpish
Level 2
Level 2
Posts: 54
Joined: Sun Jul 25, 2010 4:33 pm

Re: Screen suspending after 10 minutes of inactivity

Postby rolandpish » Tue Sep 28, 2010 3:00 pm

robert-e wrote:Acutally, the only time it really bugs me, is when I am expecting an email from the gmail server, and I look over at the computer to see if it has arrived, only to see the darn blank screen. I have then to walk over and move the mouse to see the screen; every ten minutes.

This is exactly my scenario also, so that's why this bug annoys me.

robert-e wrote:I am suspecting that it is a kernel problem

At first I suspected such a thing and I installed the Liquorix 2.6.35-6.dmz kernel and the problem persists the same as with 2.6.32-5-686 kernel.

So, I'll wait for a solution while I move my mouse every 10 minutes just to check if my emails have arrived :)

Thanks!

vincent
Level 8
Level 8
Posts: 2218
Joined: Tue Feb 09, 2010 4:10 am

Re: Screen suspending after 10 minutes of inactivity

Postby vincent » Tue Sep 28, 2010 3:04 pm

Just making sure we aren't missing anything obvious...for those of you using Gnome, have you checked Control Centre > Screensaver, and made sure that "Activate screensaver when computer is idle" is unchecked?
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm

User avatar
tdockery97
Level 14
Level 14
Posts: 5020
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon
Contact:

Re: Screen suspending after 10 minutes of inactivity

Postby tdockery97 » Tue Sep 28, 2010 5:17 pm

Hi vincent. I too experience this. I do all the power settings (including what you said above) and everything is fine during the current session. But if I shutdown and start up next morning, I find that the settings weren't persistent. I have to go back and "make default" again. This must be a bug in Control Center as it does the same no matter what kernel is used. I've never mentioned it because it's easy to go in and redo the default, but I can see where some people would be irritated by it. :)
Image

robert-e
Level 3
Level 3
Posts: 156
Joined: Fri Nov 27, 2009 1:38 am

Re: Screen suspending after 10 minutes of inactivity

Postby robert-e » Tue Sep 28, 2010 6:41 pm

Vincent,
Yes, that is the first thing I tried. The reason I suspected the kernel was that it also occured in KDE, as well as gnome. Yet, I know so little about linux kernels that I would be the first to admit I could be wrong.
OTOH, I have seen a general movement in both Fedora, and Ubuntu/Mint towards "protecting users from themselves" in the last while. Many things are now default, and getting quite hard to mitigate. When things are built into gnome, or the kernel, user choice seems to get more dificult. I refer to such things as "no ctl/alt/bsp", the networked audio server PulseAudio, default LVM, the "becoming next-to useless" text-based install option, gnome's Window's-like "register", no-root gui login, none-root software updating (fedora), Network Manager becoming sole connection tool. I imagine if I thought about this trend some more, I could add to the list. I won't because it is useless; if only because someone will come along and chastise me as a promoter of dangerous thoughts. LOL

Anyway, time for coffee.
Enjoy what we have.
Regards,
Bob

RHTopics
Level 1
Level 1
Posts: 34
Joined: Fri Sep 10, 2010 2:32 pm

It Could Be The DPMS Setting In Xorg

Postby RHTopics » Tue Sep 28, 2010 7:05 pm

Another possible place to look is your DPMS settings in your /etc/X11/xorg.conf file.

With DPMS enabled it can control when the screen goes blank after a certain amount of inactivity.

If you don't have a xorg.conf file, then DPMS may still be enabled. Do the command "xset q" in a terminal window to get information about your current X window settings.

rolandpish
Level 2
Level 2
Posts: 54
Joined: Sun Jul 25, 2010 4:33 pm

Re: Screen suspending after 10 minutes of inactivity

Postby rolandpish » Wed Sep 29, 2010 9:35 am

RHTopics wrote:Another possible place to look is your DPMS settings in your /etc/X11/xorg.conf file.

With DPMS enabled it can control when the screen goes blank after a certain amount of inactivity.

If you don't have a xorg.conf file, then DPMS may still be enabled. Do the command "xset q" in a terminal window to get information about your current X window settings.


This is the DPMS output of "xset q" command:

Code: Select all

DPMS (Energy Star):
  Standby: 3600    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On


3600 = 60 minutes that I setup in Xfce energy settings at first.

RHTopics
Level 1
Level 1
Posts: 34
Joined: Fri Sep 10, 2010 2:32 pm

Re: Screen suspending after 10 minutes of inactivity

Postby RHTopics » Wed Sep 29, 2010 2:29 pm

Might be worth a shot just turning off DPMS temporarily with the command:

Code: Select all

xset -dpms


DPMS would be turned off until the Xserver is restarted or you turn it back on with the command:

Code: Select all

xset +dpms


Also, check your BIOS for energy saver settings along with the what ever settings can be directly made to the monitor itself.

RelentlessDespot
Level 1
Level 1
Posts: 13
Joined: Wed Sep 15, 2010 9:37 pm

Re: Screen suspending after 10 minutes of inactivity

Postby RelentlessDespot » Wed Sep 29, 2010 10:43 pm

Same thing was happening to me.. I tried everything I could and nothing solved it.
Finally did a reinstall and poof the issue was gone.

I still have no idea what it was but as usual no two installs of the same OS are the same.

StanTheMan
Level 5
Level 5
Posts: 577
Joined: Fri Feb 13, 2009 7:07 pm

Re: Screen suspending after 10 minutes of inactivity

Postby StanTheMan » Thu Sep 30, 2010 7:35 pm

I have LMDE with Gnome. I solved the problem by raising the Screensaver time to 2 hours and unchecking he two activate settings.
I never had this problem with Isadora.

badluckchild
Level 1
Level 1
Posts: 5
Joined: Sun Feb 21, 2010 1:00 pm

Re: Screen suspending after 10 minutes of inactivity

Postby badluckchild » Thu Oct 21, 2010 5:21 pm

I am still having the same problem for a year now. All screensaver settings are fine, no matter what-blank screen in exactly 10 minutes.This has happened in Ubuntu back in 06 or 07, the post are still out there but nothing helped. Running Mint 8 and love it otherwise.

elmanuelito
Level 1
Level 1
Posts: 1
Joined: Thu Jan 13, 2011 12:02 pm

Re: Screen suspending after 10 minutes of inactivity

Postby elmanuelito » Thu Jan 13, 2011 12:07 pm

Hi
I used to have this problem as well. Setting the DPMS times (or maybe the blank time ) helped. I found a good explanation here:
http://www.shallowsky.com/linux/x-screen-blanking.html

There is another post related:
http://forums.linuxmint.com/viewtopic.php?f=141&t=57285

Hope this will be useful!
Last edited by elmanuelito on Thu Jan 13, 2011 12:21 pm, edited 1 time in total.

rolandpish
Level 2
Level 2
Posts: 54
Joined: Sun Jul 25, 2010 4:33 pm

Re: Screen suspending after 10 minutes of inactivity

Postby rolandpish » Thu Jan 13, 2011 12:16 pm

My laptop's hard disk fried, so I bought a new one and installed LMDE 201101 + Gnome and the problem never happened again :)
(I'll have to test it in my main desktop)

I haven't tested the problem in Xfce in this fresh installation because I loved so much the Gnome Mint-X theme. Furthermore, this LMDE+Gnome is really fast and never managed to have this Mint-X theme window style/borders working in Xfce.

Cheers


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests