password keyring does not unlock on auto login (solved)

Archived topics about LMDE 1
Forum rules
titus
Level 1
Level 1
Posts: 37
Joined: Sun Sep 06, 2009 4:02 am

password keyring does not unlock on auto login (solved)

Postby titus » Mon Apr 18, 2011 3:43 pm

Hello,
I've posted on this before but perhaps I didn't get the subject right.
Since a recent update whenever I am using the browser (Chromium) and I want to log on to a site, say, Mint Forums, my saved passwords don't work because the keyring has not unlocked. I have to enter my system password before I can log on with my site password.
It's a minor irritation but the only one which I have with Mint Debian and I'm sure it must be curable. Unlocking the keyring manually at the start of each session works but it doesn't remain unlocked.
I log in automatically and I'm using Mint LMDE 64 bit with an Xfce desktop.
Any suggestions, (other than logging in with my password) gratefully acknowledged.
Last edited by titus on Tue Apr 19, 2011 8:57 am, edited 1 time in total.

User avatar
mads
Level 6
Level 6
Posts: 1301
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: password keyring does not unlock on auto login

Postby mads » Mon Apr 18, 2011 7:39 pm

Try this:

1) In terminal, run these commands:
cd .gnome2/keyrings/
ls

2) Do you see a file called "default.keyring"?

2a) If no, close the Terminal. Nothing more to do.
2b) If yes, backup "default.keyring" (we are going to delete it. See next step) with this command:
sudo mv default.keyring default.keyring-old

3) Delete "default.keyring" with this command:
sudo rm default.keyring

4) Reboot

5) This time if Network Manager or any other application asks for a password, you should leave the fields
blank and hit ENTER. If any warning pop up, ignore it.

6) Try another reboot to see if you have achieved your goal.

titus
Level 1
Level 1
Posts: 37
Joined: Sun Sep 06, 2009 4:02 am

Re: password keyring does not unlock on auto login

Postby titus » Tue Apr 19, 2011 2:11 am

Thank you mads,
That worked well, it's the only problem I've had with LMDE since the beginning and it was a minor problem at that. Now, thanks to you, I don't have any issues.

User avatar
mads
Level 6
Level 6
Posts: 1301
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: password keyring does not unlock on auto login

Postby mads » Tue Apr 19, 2011 4:12 am

titus wrote:Thank you mads,
That worked well, it's the only problem I've had with LMDE since the beginning and it was a minor problem at that. Now, thanks to you, I don't have any issues.

Great! Now that I am sure it works, I go and try this myself. :lol:
Just kidding. Thanks titus, glad that it is sorted out now. :)
If you get a chance, please add [SOLVED] to the title of your thread.


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 1 guest