Seemingly Unrelated Java Issues

Archived topics about LMDE 1
Forum rules
Level 2
Level 2
Posts: 82
Joined: Sat Oct 16, 2010 1:53 pm
Location: Canada

Seemingly Unrelated Java Issues

Postby gavinhc » Fri May 13, 2011 5:53 pm

Last night, I tried to open Minecraft and it crashed almost immediately producing an error log file that starts like this

Code: Select all

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007ff3c41b4a29, pid=3261, tid=140684845795072
# JRE version: 6.0_24-b07
# Java VM: Java HotSpot(TM) 64-Bit Server VM (19.1-b02 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V  []
The error log goes on list what appear to be a bunch of memory locations saying that they are pointing to an unknown location. As you can see above, this is using the proprietary JVM distributed by Oracle. Thinking it might be a problem with the game's files since it is still in beta, I forced a reinstall and got the same error. I also tried opening it with the OpenJDK JVM, but that crashed with the same error.

Things got more interesting today when I tried to open RSSOwl, another program using Java (and Eclipse). This produced an entirely different error message

Code: Select all

java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.rssowl.ui 1 0 2011-05-13 10:20:20.051
!MESSAGE RSSOwl Starting Up (RSSOwl/ (X11; U; en))

!ENTRY org.rssowl.ui 4 4 2011-05-13 10:20:22.457
!MESSAGE read past EOF
Followed by dumping the Java stack.

Since these are two very different errors and applications, I wouldn't think that they are related, but it seems too coincidental that two Java programs would develop problems simultaneously.

I have looked at my apt logs and there is no evidence of any updates to any of the installed JVMs or RSSOwl recently. There also haven't been any Minecraft updates recently. I would try purging the proprietary JVM and reinstalling it, but 1) the OpenJDK JVM displayed the same issue 2) uninstalling sun-java6-jre also wants to uninstall some mint-debian packages.

Any ideas about what could be causing this?

Edit: I forgot to mention that I have been using both of these programs without issue since I installed the 201012 spin of LMDE.
Last edited by gavinhc on Sat May 14, 2011 1:18 pm, edited 1 time in total.
AMD Athlon II X4 630, 4 GB DDR3 RAM, Nvidia GeForce GT 430 - 64-bit LMDE (Gnome3) tracking testing, 64-bit Archlinux, 32-bit Windows XP
Aluminum Unibody MacBook - MacOS X 10.7 "Lion"

User avatar
Level 17
Level 17
Posts: 7289
Joined: Mon May 04, 2009 8:31 pm

Re: Seemingly Unrelated Java Issues

Postby richyrich » Fri May 13, 2011 7:06 pm

ahhh . . . I love my 32 bit . . . please, stick to your 64, it'll work . . eventually . . ! . . :P

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 0 guests